Bug 1304889 - Memory leak in dht
Memory leak in dht
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
3.7.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijay Bellur
:
Depends On: 1303945
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 17:10 EST by Vijay Bellur
Modified: 2016-04-19 03:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1303945
Environment:
Last Closed: 2016-04-19 03:23:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijay Bellur 2016-02-04 17:10:00 EST
+++ This bug was initially created as a clone of Bug #1303945 +++

Description of problem:

Any rename operation causes a leak in dht. This is due to a dictionary which is not being currently freed in dht_do_rename(). 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Perform renames on a fuse/nfs mount point
2. Check the memory usage of fuse client or nfs server


Actual results:
Memory usage increases with more renames being done.

Expected results:
Memory usage should remain stable even with multiple renames.


Additional info:
Comment 1 Vijay Bellur 2016-02-04 17:13:28 EST
REVIEW: http://review.gluster.org/13358 (cluster/dht: Cleanup dict in dht_do_rename()) posted (#1) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)
Comment 2 Vijay Bellur 2016-02-08 08:26:34 EST
COMMIT: http://review.gluster.org/13358 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 3db831788c3bd0d0a47466ad715894d27535e1b9
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Fri Jan 29 15:59:24 2016 -0500

    cluster/dht: Cleanup dict in dht_do_rename()
    
    Change-Id: Ib4b3a843e78eccf5b8e0e7776cd0128013a59a3e
    BUG: 1304889
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/13322
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/13358
Comment 3 Vijay Bellur 2016-02-25 00:29:01 EST
REVIEW: http://review.gluster.org/13513 (dht: cleanup dict and free memory in rename code path) posted (#1) for review on release-3.7 by Sakshi Bansal
Comment 4 Vijay Bellur 2016-02-25 22:19:42 EST
COMMIT: http://review.gluster.org/13513 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 06b31594bfdc22220e9d7875d19f476cc8d3c426
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Mon Feb 8 12:14:12 2016 +0530

    dht: cleanup dict and free memory in rename code path
    
    Backport of http://review.gluster.org/#/c/13392/
    
    > Change-Id: I2458e18197bdf7565563a85e9021b5b2850c1825
    > BUG: 1303945
    > Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    > Reviewed-on: http://review.gluster.org/13392
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    BUG: 1304889
    Change-Id: Ibda96769be2bd5b2708066d83363633fd7286929
    Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/13513
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 5 Kaushal 2016-04-19 03:23:04 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 6 Kaushal 2016-04-19 03:41:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.8, please open a new bug report.

glusterfs-3.7.8 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.