Bug 1304891 - Incremental update from UI on a child content view is not propagating automatically to composite content view
Incremental update from UI on a child content view is not propagating automat...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management (Show other bugs)
6.1.6
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: Justin Sherrill
jcallaha
http://projects.theforeman.org/issues...
: PrioBumpQA, Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 17:17 EST by sthirugn@redhat.com
Modified: 2017-12-01 05:28 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:28:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
propagate update (102.32 KB, image/png)
2016-07-06 12:08 EDT, jcallaha
no flags Details
screen showing what a composite incremental update looks like (36.94 KB, image/png)
2016-07-07 10:05 EDT, Justin Sherrill
no flags Details
verification 1 (99.25 KB, image/png)
2016-07-07 12:06 EDT, jcallaha
no flags Details
verification 2 (71.04 KB, image/png)
2016-07-07 12:06 EDT, jcallaha
no flags Details
verification 3 (101.29 KB, image/png)
2016-07-07 12:06 EDT, jcallaha
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14399 None None None 2016-04-22 11:35 EDT

  None (edit)
Description sthirugn@redhat.com 2016-02-04 17:17:43 EST
Description of problem:
Incremental update from UI on a child content view is not propagating automatically to composite content view

Version-Release number of selected component (if applicable):
Sat 6.1.6

How reproducible:
Always

Steps to Reproduce:
1. Create a content view, add repos, publish, promote
2. Create a composite content view with content view from step1 and select the latest version, publish, promote
3. Incremental update the content view from Step 1


Actual results:
The composite content view is not automatically updated

Expected results:
The composite content view should be automatically updated

Additional info:
Comment 1 sthirugn@redhat.com 2016-02-04 17:18:22 EST
Correction: All the steps mentioned in `Steps to Reproduce` are done from Satellite 6 Web UI
Comment 2 sthirugn@redhat.com 2016-02-04 17:31:18 EST
There are no errors in the logs, but the logic to update composites is totally missed.
Comment 6 Justin Sherrill 2016-03-30 12:46:29 EDT
Created redmine issue http://projects.theforeman.org/issues/14399 from this bug
Comment 8 Bryan Kearney 2016-04-13 16:11:05 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14399 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|efe6fac6b679ab697dabe1ba263fa0fd22383b49.
Comment 9 Brad Buckingham 2016-04-21 11:35:01 EDT
WORKAROUND: Utilize the Hammer CLI to perform the incremental update.  For example, the following will incrementally update the component view version (13) and propagate the update to the any composite views utilizing it:

content-view version incremental-update --organization-id 1 --content-view-version-id 13  --errata-ids RHEA-2012:0002 --propagate-all-composites true
Comment 10 jcallaha 2016-07-06 12:07:32 EDT
Failed QA in Satellite 6.2 Beta Snap 18.2

After incremental update, the composite view is not automatically pulling in the new version. Perhaps we can offer a choice during the update process like I show in my attached screenshot.
Comment 11 jcallaha 2016-07-06 12:08 EDT
Created attachment 1176939 [details]
propagate update
Comment 12 Justin Sherrill 2016-07-07 10:04:55 EDT
I think there may be a misunderstanding how this works.  The behavior automatically works against composite content views only when you've selected a system that is within a composite content view.  In that case the component will be updated and that will be pushed to the composite.

The feature you mention would be a feature request.  See my attached screenshot for what the actual page looks like. Moving back to ON_QA
Comment 13 Justin Sherrill 2016-07-07 10:05 EDT
Created attachment 1177341 [details]
screen showing what a composite incremental update looks like
Comment 14 jcallaha 2016-07-07 12:05:40 EDT
Verified in Satellite 6.2 Beta Snap 19.

Incremental update is working as expected per Justin's comment above. See attached screenshots for verification.
Comment 15 jcallaha 2016-07-07 12:06 EDT
Created attachment 1177377 [details]
verification 1
Comment 16 jcallaha 2016-07-07 12:06 EDT
Created attachment 1177378 [details]
verification 2
Comment 17 jcallaha 2016-07-07 12:06 EDT
Created attachment 1177379 [details]
verification 3
Comment 18 Bryan Kearney 2016-07-27 07:28:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.