Bug 1304902 - blivet.errors.DeviceTreeError: failed to add slave pdc_bcfcbhda of device pdc_bcfcbhda1
blivet.errors.DeviceTreeError: failed to add slave pdc_bcfcbhda of device pdc...
Status: CLOSED DUPLICATE of bug 1297624
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:93b0f35ba487e9c91df512c47f6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 18:37 EST by nw.whitecrow
Modified: 2016-06-06 20:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-06 20:32:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (543.66 KB, text/plain)
2016-02-04 18:37 EST, nw.whitecrow
no flags Details
File: anaconda.log (8.13 KB, text/plain)
2016-02-04 18:37 EST, nw.whitecrow
no flags Details
File: environ (537 bytes, text/plain)
2016-02-04 18:37 EST, nw.whitecrow
no flags Details
File: journalctl (357.18 KB, text/plain)
2016-02-04 18:37 EST, nw.whitecrow
no flags Details
File: lsblk_output (3.43 KB, text/plain)
2016-02-04 18:37 EST, nw.whitecrow
no flags Details
File: nmcli_dev_list (2.58 KB, text/plain)
2016-02-04 18:37 EST, nw.whitecrow
no flags Details
File: os_info (518 bytes, text/plain)
2016-02-04 18:37 EST, nw.whitecrow
no flags Details
File: program.log (28.37 KB, text/plain)
2016-02-04 18:37 EST, nw.whitecrow
no flags Details
File: storage.log (121.15 KB, text/plain)
2016-02-04 18:37 EST, nw.whitecrow
no flags Details
File: ifcfg.log (7.70 KB, text/plain)
2016-02-04 18:37 EST, nw.whitecrow
no flags Details

  None (edit)
Description nw.whitecrow 2016-02-04 18:37:04 EST
Description of problem:
When anaconda installer launches from Fedora live USB, it freezes on the very first page with language selection menus, and then exits with an error.

Version-Release number of selected component:
anaconda-core-23.19.10-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 274, in _addSlaveDevices
    raise DeviceTreeError(msg)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 305, in addUdevDMDevice
    slave_devices = self._addSlaveDevices(info)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 715, in addUdevDevice
    device = self.addUdevDMDevice(info)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1692, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1623, in populate
    self._populate()
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 554, in populate
    self._populator.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 279, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/osinstall.py", line 1157, in storageInitialize
    storage.reset()
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 171, in raise_if_error
    raise exc_info[0](exc_info[1]).with_traceback(exc_info[2])
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 116, in wait
    self.raise_if_error(name)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/timezone.py", line 76, in time_initialize
    threadMgr.wait(THREAD_STORAGE)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
blivet.errors.DeviceTreeError: failed to add slave pdc_bcfcbhda of device pdc_bcfcbhda1

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:LABEL=UUI NULL=Fedora-Live-WS-x86_64-23-10 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.12.8-1.fc23.noarch
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 nw.whitecrow 2016-02-04 18:37:11 EST
Created attachment 1121249 [details]
File: anaconda-tb
Comment 2 nw.whitecrow 2016-02-04 18:37:13 EST
Created attachment 1121250 [details]
File: anaconda.log
Comment 3 nw.whitecrow 2016-02-04 18:37:14 EST
Created attachment 1121251 [details]
File: environ
Comment 4 nw.whitecrow 2016-02-04 18:37:17 EST
Created attachment 1121252 [details]
File: journalctl
Comment 5 nw.whitecrow 2016-02-04 18:37:19 EST
Created attachment 1121253 [details]
File: lsblk_output
Comment 6 nw.whitecrow 2016-02-04 18:37:20 EST
Created attachment 1121254 [details]
File: nmcli_dev_list
Comment 7 nw.whitecrow 2016-02-04 18:37:22 EST
Created attachment 1121255 [details]
File: os_info
Comment 8 nw.whitecrow 2016-02-04 18:37:25 EST
Created attachment 1121256 [details]
File: program.log
Comment 9 nw.whitecrow 2016-02-04 18:37:27 EST
Created attachment 1121257 [details]
File: storage.log
Comment 10 nw.whitecrow 2016-02-04 18:37:28 EST
Created attachment 1121258 [details]
File: ifcfg.log
Comment 11 Anijatsu 2016-02-10 08:03:56 EST
Another user experienced a similar problem:

Entered the instaaller

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=FEDORA-LIVE ro rd.live.image quiet rhgb rd.live.check
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.12.8-1.fc23.noarch
package:        anaconda-core-23.19.10-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         blivet.errors.DeviceTreeError: failed to add slave sil_ccacadcdbiff of device sil_ccacadcdbiff1
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 12 Brian Lane 2016-06-06 20:32:25 EDT

*** This bug has been marked as a duplicate of bug 1297624 ***

Note You need to log in before you can comment on or make changes to this bug.