Bug 1304953 - Rebase libstoragemgmt to latest upstream version
Rebase libstoragemgmt to latest upstream version
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libstoragemgmt (Show other bugs)
7.3
All Linux
high Severity medium
: beta
: ---
Assigned To: Gris Ge
Bruno Goncalves
: Rebase
Depends On: 1355637 1360177
Blocks: 1298558 1313485 1295577 1364088
  Show dependency treegraph
 
Reported: 2016-02-04 23:20 EST by Gris Ge
Modified: 2016-11-04 02:09 EDT (History)
7 users (show)

See Also:
Fixed In Version: libstoragemgmt-1.3.4-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:09:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2016-02-04 23:20:08 EST
Description of problem:

Rebase libstoragemgmt to latest upstream version to include features:
 * Fixed for local hardware RAID plugin hpsa and megaraid.
 * Library level API for local disk info query.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 6 Gris Ge 2016-08-01 03:36:56 EDT
Rebased to 1.3.3.

Issue fixd besides existing bugs:
 * HPSA: Fix PLUGIN_BUG error when disk is not exposed to OS.
   https://github.com/libstorage/libstoragemgmt/issues/167
 * Seg fault on qemu simulated disk when 'lsmcli ldl'.
Comment 7 Bruno Goncalves 2016-08-02 08:33:32 EDT
Passed in our regression test using libstoragemgmt-1.3.3-1.el7
Comment 8 Gris Ge 2016-08-03 09:21:41 EDT
Rebased to 1.3.4.

Changes since 1.3.3:
 * Fix a hpsa plugin incorrect constant:
   https://github.com/libstorage/libstoragemgmt/pull/177
Comment 10 errata-xmlrpc 2016-11-04 02:09:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2415.html

Note You need to log in before you can comment on or make changes to this bug.