Bug 1304982 - Gnocchi-dispatcher options are missing from ceilometer.conf
Gnocchi-dispatcher options are missing from ceilometer.conf
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
9.0 (Mitaka)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 9.0 (Mitaka)
Assigned To: Pradeep Kilambi
Yurii Prokulevych
: Triaged
Depends On: 1258947 1353929
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 02:58 EST by Yurii Prokulevych
Modified: 2016-08-11 08:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-ceilometer-6.1.1-1.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, gnocchi-dispatcher options were not present in `ceilometer.conf` by default. Consequently, the options had to be manually added. With this update, the gnocchi-dispatcher options are included by default when ceilometer is installed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 08:14:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yurii Prokulevych 2016-02-05 02:58:45 EST
Description of problem:
Options relevant to gnocchi dispatcher are missing from ceilometer.conf

filter_service_activity, filter_project, url, archive_policy, resources_definition_file

Version-Release number of selected component (if applicable):
ceilometer*-5.0.1-1.el7ost.noarch

How reproducible:
100%

Expected results:
Options are present in ceilometer.conf

---
Yurii
Comment 2 Yurii Prokulevych 2016-02-05 02:59:54 EST
Similar issue: rhbz 1265746
Comment 5 Yurii Prokulevych 2016-07-20 08:30:39 EDT
Verified with packages:
-----------------------
openstack-ceilometer-central-6.1.1-1.el7ost.noarch
python-ceilometerclient-2.3.0-1.el7ost.noarch
openstack-ceilometer-polling-6.1.1-1.el7ost.noarch
python-ceilometer-6.1.1-1.el7ost.noarch
openstack-ceilometer-common-6.1.1-1.el7ost.noarch
openstack-ceilometer-collector-6.1.1-1.el7ost.noarch
openstack-ceilometer-notification-6.1.1-1.el7ost.noarch
openstack-ceilometer-api-6.1.1-1.el7ost.noarch
openstack-ceilometer-compute-6.1.1-1.el7ost.noarch

Excerpt of ceilometer.conf:
[dispatcher_gnocchi]

#
# From ceilometer
#

# Filter out samples generated by Gnocchi service activity (boolean value)
#filter_service_activity = true

# Gnocchi project used to filter out samples generated by Gnocchi service
# activity (string value)
#filter_project = gnocchi
filter_project=service

# URL to Gnocchi. default: autodetection (string value)
# This option is deprecated for removal.
# Its value may be silently ignored in the future.
#url = <None>
url=http://192.0.2.22:8041

# The archive policy to use when the dispatcher create a new metric. (string
# value)
#archive_policy = <None>
archive_policy=low

# The Yaml file that defines mapping between samples and gnocchi
# resources/metrics (string value)
#resources_definition_file = gnocchi_resources.yaml
resources_definition_file=gnocchi_resources.yaml
Comment 7 errata-xmlrpc 2016-08-11 08:14:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1597.html

Note You need to log in before you can comment on or make changes to this bug.