Bug 1304988 - DHT: Rebalance hang while migrating the files of disperse volume
DHT: Rebalance hang while migrating the files of disperse volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ashish Pandey
Bhaskarakiran
:
Depends On: 1264310
Blocks: 1322299
  Show dependency treegraph
 
Reported: 2016-02-05 03:49 EST by Ashish Pandey
Modified: 2016-11-23 18:12 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1264310
: 1322299 (view as bug list)
Environment:
Last Closed: 2016-06-23 04:43:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-17 05:31:33 EST
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#1) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 2 Vijay Bellur 2016-02-23 00:38:01 EST
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 3 Vijay Bellur 2016-02-23 04:12:54 EST
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#3) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 4 Vijay Bellur 2016-02-24 13:47:07 EST
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#4) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 5 Vijay Bellur 2016-03-07 06:34:44 EST
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#5) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 6 Vijay Bellur 2016-03-08 02:10:56 EST
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#6) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 7 Vijay Bellur 2016-03-09 01:39:51 EST
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#7) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 8 Vijay Bellur 2016-03-10 00:03:06 EST
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#8) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 9 Vijay Bellur 2016-03-16 06:55:17 EDT
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#9) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 10 Vijay Bellur 2016-03-16 07:24:27 EDT
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#10) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 11 Vijay Bellur 2016-03-17 03:21:23 EDT
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#11) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 12 Vijay Bellur 2016-03-17 12:46:43 EDT
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#12) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 13 Vijay Bellur 2016-03-20 05:38:57 EDT
REVIEW: http://review.gluster.org/13460 (cluster/ec: Rebalance hangs during rename) posted (#13) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 14 Mike McCune 2016-03-28 18:17:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 15 Vijay Bellur 2016-03-30 04:51:17 EDT
COMMIT: http://review.gluster.org/13460 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 7bbcd6fb692dffc628b723eace8cfcfa466e606f
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Wed Feb 17 15:57:02 2016 +0530

    cluster/ec: Rebalance hangs during rename
    
    Problem:
    During the rename of a particular file (ec
    is holding blocking inodelk on the parent
    directory), if the rename of another file
    under the same directory comes. EC does not
    release the lock and goes ahead and renames
    the "new" file with the "already held lock".
    
    That causes rebalance process to be blocked
    on a lock which has been acquired by rename.
    
    Solution:
    While rename fop comes, ec takes blocking inodelk
    on old and new parent of the file. Before releasing,
    every lock held by ec, it waits for some "time" to
    see if that lock can be reused by the next fop.
    If within this "time" some other request comes,
    it releases this lock based on condition
    "lock count > 1"
    
    To get this "lock count" for rename fop, we have
    implemented "pl_rename" in feature/lock. Also,
    on ec side, changed the condition to release the lock
    based on the type of fop and old and new parent
    directories.
    
    Change-Id: I979dbab1185df962e8f305a6074ae1186ffe7db0
    Bug: 1304988
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/13460
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
Comment 16 Vijay Bellur 2016-04-01 04:13:19 EDT
REVIEW: http://review.gluster.org/13883 (feature/locks : Add pl-messages.h file in Makefile.am) posted (#1) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 17 Vijay Bellur 2016-04-01 04:48:18 EDT
REVIEW: http://review.gluster.org/13883 (feature/locks : Add pl-messages.h file in Makefile.am) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 18 Niels de Vos 2016-06-23 04:43:13 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1] a while back, and packages for several distributions should be available by now.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/

Note You need to log in before you can comment on or make changes to this bug.