Bug 1304990 - [RFE] Contract Improvements
[RFE] Contract Improvements
Status: CLOSED CURRENTRELEASE
Product: vdsm-jsonrpc-java
Classification: oVirt
Component: RFEs (Show other bugs)
1.2
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.0-beta
: 1.2.3
Assigned To: Piotr Kliczewski
Piotr Kliczewski
: CodeChange, FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 04:15 EST by Piotr Kliczewski
Modified: 2016-08-11 04:50 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 04:50:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
mgoldboi: planning_ack+
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description Piotr Kliczewski 2016-02-05 04:15:02 EST
We want to improve how what data is sent to different versions of vdsm or ovirt-engine. By having this mechanism we can keep well defined interface between vdsm and ovirt-engine which enable us to evolve APIs.

In order to make it happen we need to:
- convert existing api schema from json like format to yaml
- start using new schema on both sides
- add event format to the schema
- enforce contract on both sides
Comment 2 Sandro Bonazzola 2016-05-02 06:06:20 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 3 Pavel Stehlik 2016-05-05 09:30:55 EDT
QE - CodeChange, thus just sanity.
Comment 4 Oved Ourfali 2016-05-09 02:52:01 EDT
The following was posted:
1. convert existing api schema from json like format to yaml
2. start using new schema on VDSM
3. add event format to the schema
Comment 5 Oved Ourfali 2016-05-18 10:07:07 EDT
Only the first two will be part of this RFE.
The third item will be pushed as part of another RFE (yet to be opened), hopefully accepted as an exception to 4.0.
Comment 6 Gil Klein 2016-08-11 04:50:33 EDT
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.