Bug 1305012 - Pod keeps restarting to CrashLoopBackOff status when use jenkins-persistent template for jenkins-1-rhel7 image
Pod keeps restarting to CrashLoopBackOff status when use jenkins-persistent t...
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ben Parees
Wang Haoran
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 05:29 EST by Wenjing Zheng
Modified: 2016-02-05 21:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 21:48:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wenjing Zheng 2016-02-05 05:29:06 EST
Description of problem:
Pod keeps restarting and in CrashLoopBackOff status when use jenkins-persistent template for below error:
[root@10 ~]# docker logs 73df86769f18
Detected password change, updating Jenkins configuration ...
sed: couldn't open temporary file /var/lib/jenkins/users/admin/seda8oTkk: Permission denied
/usr/libexec/s2i/run: line 49: /var/lib/jenkins/password: Permission denied
Running from: /usr/lib/jenkins/jenkins.war
webroot: EnvVars.masterEnvVars.get("JENKINS_HOME")
Feb 05, 2016 5:07:53 AM winstone.Logger logInternal
INFO: Beginning extraction from war file

Version-Release number of selected component (if applicable):
jenkins-1-rhel7 f708901345d7

How reproducible:
Always

Steps to Reproduce:
1. Create pv in master
2. Create project
3. Create with jenkins-persistent template
4. Check pod status

Actual results:
Pod keeps restarting

Expected results:
Pod should be running

Additional info:
Comment 1 Ben Parees 2016-02-05 15:09:04 EST
This most likely indicates a problem with the underlying PV, can you provide details about the PV you configured?
Comment 2 Wenjing Zheng 2016-02-05 21:48:01 EST
Yes, seems env have some problem, closing this bug as not a bug. pod is running with persistent volum:
[wzheng@localhost ~]$ oc get pods
NAME              READY     STATUS    RESTARTS   AGE
jenkins-1-m0ju9   1/1       Running   0          5m

Note You need to log in before you can comment on or make changes to this bug.