Bug 1305026 - Multiple catalogs across tenants with the same name in the accordion tree
Multiple catalogs across tenants with the same name in the accordion tree
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity medium
: GA
: 5.6.0
Assigned To: Milan Zázrivec
Matouš Mojžíš
tenant_cfme:ui
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 06:17 EST by Pavol Kotvan
Modified: 2017-08-29 21:19 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:36:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CatalogItems with tenant catalogs (69.99 KB, image/png)
2016-04-27 07:27 EDT, Matouš Mojžíš
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 14:50:04 EDT

  None (edit)
Comment 5 Milan Zázrivec 2016-04-12 12:36:36 EDT
https://github.com/ManageIQ/manageiq/pull/7903
Comment 6 CFME Bot 2016-04-18 13:56:05 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/eadc6b2cc3456a20c1e362b4645eb06ac6804ac9

commit eadc6b2cc3456a20c1e362b4645eb06ac6804ac9
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Tue Apr 12 18:31:47 2016 +0200
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Wed Apr 13 11:18:00 2016 +0200

    Show tenant name next to service template name in catalog tree
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1305026

 app/presenters/tree_node_builder.rb       | 7 ++++++-
 spec/presenters/tree_node_builder_spec.rb | 4 +++-
 2 files changed, 9 insertions(+), 2 deletions(-)
Comment 7 Matouš Mojžíš 2016-04-27 07:02:52 EDT
Tested in version 5.6.0.4-beta2.3.20160421172650_719e256.
In Services -> Catalogs -> Catalogs -> All catalogs I can see column tenant, which identifies tenant, who created that catalog.
But in Services -> Catalogs -> Catalog items -> All catalogs I can't identify catalogs with same name, which were created by different tenants (can see that in attachment).
So I return it back on dev.
Comment 8 Matouš Mojžíš 2016-04-27 07:03 EDT
Created attachment 1151291 [details]
Catalog items with tenant catalogs
Comment 9 Matouš Mojžíš 2016-04-27 07:27 EDT
Created attachment 1151297 [details]
CatalogItems with tenant catalogs
Comment 10 Milan Zázrivec 2016-04-27 08:39:14 EDT
https://github.com/ManageIQ/manageiq/pull/8284
Comment 11 CFME Bot 2016-04-28 17:35:39 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/1d5a18c3c1bc429f94ecccd6ccc61615b1828238

commit 1d5a18c3c1bc429f94ecccd6ccc61615b1828238
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Wed Apr 27 14:37:16 2016 +0200
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Wed Apr 27 17:37:26 2016 +0200

    Show tenant name next to service template catalog in catalog tree
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1305026

 app/controllers/catalog_controller.rb     | 7 ++++---
 app/presenters/tree_node_builder.rb       | 7 ++++++-
 spec/presenters/tree_node_builder_spec.rb | 4 +++-
 3 files changed, 13 insertions(+), 5 deletions(-)
Comment 12 Matouš Mojžíš 2016-05-05 08:22:33 EDT
Verified in 5.6.0.5-beta2.4.20160503153816_1fb554f.
In Catalog items is catalog creator in brackets.
Comment 15 errata-xmlrpc 2016-06-29 11:36:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.