Bug 1305039 - database-service-1.1.0.redhat-4.jar loaded instead of database-service-1.1.0.redhat-6.jar
database-service-1.1.0.redhat-4.jar loaded instead of database-service-1.1.0....
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Alex Szczuczko
Filip Elias
:
Depends On:
Blocks: 1307150
  Show dependency treegraph
 
Reported: 2016-02-05 07:23 EST by Cojan van Ballegooijen
Modified: 2016-08-24 07:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:50:16 EDT
Type: Support Patch
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (282.15 KB, text/plain)
2016-02-05 07:23 EST, Cojan van Ballegooijen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-3948 Major Resolved Provide a different mechanism to update odata wars 2017-05-19 11:48 EDT

  None (edit)
Description Cojan van Ballegooijen 2016-02-05 07:23:41 EST
Created attachment 1121373 [details]
server.log

Description of problem:
12:57:15,493 INFO  [org.jboss.dashboard.workspace.GraphicElementManagerImpl] (ServerService Thread Pool -- 68) Starting org.jboss.dashboard.workspace.SkinsManagerImpl
12:57:15,500 INFO  [org.jboss.dashboard.ui.resources.GraphicElement] (ServerService Thread Pool -- 68) Deploying files for org.jboss.dashboard.ui.resources.Skin Default_Skin
12:57:15,606 INFO  [org.jboss.dashboard.workspace.GraphicElementManagerImpl] (ServerService Thread Pool -- 68) Starting org.jboss.dashboard.workspace.EnvelopesManagerImpl
12:57:15,642 INFO  [org.jboss.dashboard.ui.resources.GraphicElement] (ServerService Thread Pool -- 68) Deploying files for org.jboss.dashboard.ui.resources.Envelope Default_Envelope
12:57:15,696 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) JBAS014612: Operation ("add") failed - address: ([("deployment" => "database-service.jar")]) - failure description: {"JBAS014671: Failed services" => {"jboss.deployment.unit.\"database-service.jar\".STRUCTURE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"database-service.jar\".STRUCTURE: JBAS018733: Failed to process phase STRUCTURE of deployment \"database-service.jar\"
    Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS018740: Failed to mount deployment content
    Caused by: java.io.FileNotFoundException: /Applications/opt/jboss/dv-6.2.0/jboss-eap-6.4/dataVirtualization/logging/database-service-1.1.0.redhat-4.jar (No such file or directory)"}}
12:57:15,734 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS015859: Deployed "database-service.jar" (runtime-name : "database-service.jar")
12:57:15,734 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS015859: Deployed "ModeShape.vdb" (runtime-name : "ModeShape.vdb")
12:57:15,734 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS015859: Deployed "teiid-dashboard-builder.war" (runtime-name : "teiid-dashboard-builder.war")
12:57:15,735 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS015859: Deployed "teiid-odata-8.7.1.6_2-redhat-6.war" (runtime-name : "teiid-odata-8.7.1.6_2-redhat-6.war")
12:57:15,735 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 30) JBAS015859: Deployed "integration-platform-console.war" (runtime-name : "integration-platform-console.war")
12:57:15,735 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 52) JBAS015859: Deployed "modeshape-cmis.war" (runtime-name : "modeshape-cmis.war")
12:57:15,735 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 52) JBAS015859: Deployed "modeshape-webdav.war" (runtime-name : "modeshape-webdav.war")
12:57:15,738 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 52) JBAS015859: Deployed "modeshape-rest.war" (runtime-name : "modeshape-rest.war")
12:57:15,738 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014777:   Services which failed to start:      service jboss.deployment.unit."database-service.jar".STRUCTURE: org.jboss.msc.service.StartException in service jboss.deployment.unit."database-service.jar".STRUCTURE: JBAS018733: Failed to process phase STRUCTURE of deployment "database-service.jar"

12:57:15,745 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management
12:57:15,745 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
12:57:15,745 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss Red Hat JBoss Data Virtualization 6.2.2 (AS 7.5.5.Final-redhat-3) started (with errors) in 12076ms - Started 887 of 930 services (1 services failed or missing dependencies, 103 services are lazy, passive or on-demand)

Version-Release number of selected component (if applicable):
/Applications/opt/jboss/dv-6.2.0/jboss-eap-6.4/dataVirtualization/logging/database-service-1.1.0.redhat-4.jar 

How reproducible:
See below

Steps to Reproduce:
1. Install JBoss EAP 6.4.0
2. Install EAP 6.4.3 Patch 
3. Install DV 6.2.0 (advanced configuration including option logging) 

Actual results:
/Applications/opt/jboss/dv-6.2.0/jboss-eap-6.4/dataVirtualization/logging/database-service-1.1.0.redhat-4.jar is being loaded by standalone.xml which does not exists and hence gives errors

Expected results:
No errors

Additional info:
/Applications/opt/jboss/dv-6.2.0/jboss-eap-6.4/dataVirtualization/logging/database-service-1.1.0.redhat-4.jar reference in standalone.xml in incorrect
should be 
/Applications/opt/jboss/dv-6.2.0/jboss-eap-6.4/dataVirtualization/logging/database-service-1.1.0.redhat-6.jar
Comment 1 Cojan van Ballegooijen 2016-02-05 07:25:48 EST
Steps to reproduce should include the following DV patch:
4. install patch BZ-1268321.zip
Comment 3 jolee 2016-03-16 16:39:28 EDT
@Alex,
  Assigning over to you for DV 6.2 Update 04 inclusion.  Discussion with Van indicates you will be aware and we will update with the tag shortly.
Comment 5 Juraj Duráni 2016-03-29 04:04:28 EDT
I can see that 6.2.4 patch contains database-service jar of version 1.1.0.redhat-4, but pom in the jar declares version 1.1.0.redhat-8. Is this intended fix for the issue. Just rename the file so re-deployment of jar is not needed?
Comment 6 Alex Szczuczko 2016-03-29 05:12:58 EDT
That is the intended fix, yes (the same thing was done for bug 1233001).

The patching system cannot effect the server configuration, so the server configuration will always reference the GA filename. Since the filename contains a version, it has to be the GA version. This is potentially confusing, but it's the best that can be done in 6.2.x. We should be able to avoid this for 6.3, by ensuring no deployments have versions in their filenames.
Comment 7 Juraj Duráni 2016-03-29 08:35:18 EDT
OK. Setting to verify.

Note You need to log in before you can comment on or make changes to this bug.