Bug 1305081 - Floating IP status is None in Multicontroller L3 router HA
Floating IP status is None in Multicontroller L3 router HA
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: z4
: 7.0 (Kilo)
Assigned To: Assaf Muller
Eran Kuris
: AutomationBlocker, Triaged, ZStream
Depends On: 1284739
Blocks: 1190166 1243520
  Show dependency treegraph
 
Reported: 2016-02-05 09:42 EST by Ihar Hrachyshka
Modified: 2016-04-26 11:20 EDT (History)
16 users (show)

See Also:
Fixed In Version: openstack-neutron-2015.1.2-9.el7ost
Doc Type: Bug Fix
Doc Text:
Prior to this update, the status of a floating IP was not set when the floating IP was realized by an HA router. As a result, `neutron floatingip-show <floating_ip>` might not have shown the updated status. This update addresses this issue by updating floating IP statuses when realized by HA routers, and when the L3 agent configures a router. As a result, the status field for any floating IPs realized by HA routers is now updated to `ACTIVE` when the floating IP is configured by the L3 agent.
Story Points: ---
Clone Of: 1284739
Environment:
Last Closed: 2016-02-18 11:08:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1449049 None None None 2016-02-05 09:42 EST
OpenStack gerrit 177777 None None None 2016-02-05 09:42 EST
OpenStack gerrit 271741 None None None 2016-02-05 09:42 EST

  None (edit)
Comment 1 Ihar Hrachyshka 2016-02-06 06:56:31 EST
I don't see flags automatically set, so I add rhos-flags@.
Comment 2 Alan Pevec 2016-02-06 08:59:31 EST
> I don't see flags automatically set, so I add rhos-flags@.

iirc bz needs Triaged in Keywords for auto-flaging to work
Comment 6 Eran Kuris 2016-02-15 05:08:43 EST
Verifies and fixed : 
[stack@undercloud ~]$ rpm -qa |grep neutron 
openstack-neutron-ml2-2015.1.2-9.el7ost.noarch
openstack-neutron-common-2015.1.2-9.el7ost.noarch
python-neutronclient-2.4.0-2.el7ost.noarch
openstack-neutron-2015.1.2-9.el7ost.noarch
openstack-neutron-openvswitch-2015.1.2-9.el7ost.noarch
python-neutron-2015.1.2-9.el7ost.noarch
[stack@undercloud ~]$ neutron floatingip-list
+--------------------------------------+------------------+---------------------+--------------------------------------+
| id                                   | fixed_ip_address | floating_ip_address | port_id                              |
+--------------------------------------+------------------+---------------------+--------------------------------------+
| d5e9a051-155b-4b1b-8475-dadeda9ee9e5 | 21.0.0.5         | 192.168.1.153       | 8a22ceb0-4647-45d3-8480-cfbd7e4442f0 |
| -------------------------------------+------------------+---------------------
[stack@undercloud ~]$ neutron floatingip-show d5e9a051-155b-4b1b-8475-dadeda9ee9e5
+---------------------+--------------------------------------+
| Field               | Value                                |
+---------------------+--------------------------------------+
| fixed_ip_address    | 21.0.0.5                             |
| floating_ip_address | 192.168.1.153                        |
| floating_network_id | 512c0106-5797-4694-b7ae-a1dbfdd670af |
| id                  | d5e9a051-155b-4b1b-8475-dadeda9ee9e5 |
| port_id             | 8a22ceb0-4647-45d3-8480-cfbd7e4442f0 |
| router_id           | eda8fca8-ec29-49fc-bdb2-a9c3af55c1a5 |
| status              | ACTIVE                               |
| tenant_id           | b2f216f62436402f98ac66f8353f3e02     |
+---------------------+--------------------------------------+
Comment 8 Ihar Hrachyshka 2016-02-16 05:14:25 EST
Moving the bug to the assignee of the original bug. The doctext should be updated for both.
Comment 10 errata-xmlrpc 2016-02-18 11:08:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0262.html

Note You need to log in before you can comment on or make changes to this bug.