This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1305104 - linked kubectl binaries do not support standard operations
linked kubectl binaries do not support standard operations
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.2.0
All All
unspecified Severity medium
: ---
: ---
Assigned To: Jason DeTiberus
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 11:02 EST by Timothy St. Clair
Modified: 2016-07-03 20:46 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 12:37:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy St. Clair 2016-02-05 11:02:50 EST
Description of problem:
We ship a softlink in our rpms: 

$ ls -la /usr/bin/kubectl
lrwxrwxrwx. 1 root root 2 Jan 29 07:45 /usr/bin/kubectl -> oc

but we don't support that all the standard operations that kubectl does.  IMHO we should strike it from our release b/c its confusing.  

Version-Release number of selected component (if applicable):
*

How reproducible:
100% 

Steps to Reproduce:
1. $ kubectl create namespace thisshouldwork

Actual results:
error: Unexpected args: [namespace thisshouldwork]

Expected results:
namespace "thisshouldwork" created

Additional info:
There are likely other operations as well. 

https://github.com/openshift/origin/issues/7063#issuecomment-180410331
Comment 1 Clayton Coleman 2016-02-06 18:48:39 EST
Those operations had not been picked up until the most recent rebase.  We plan to continue to ship this command for compatibility.  Exceptions are specific and relate to functionality upstream that is not ready to be provided to customers, like "apply" (which is now enabled as of 1.1.2).

Moving to ON_QA - this should be in master.
Comment 3 DeShuai Ma 2016-02-14 00:11:26 EST
Verify this bug, In later test QE will cover kubectl command.
Comment 5 errata-xmlrpc 2016-05-12 12:37:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1065

Note You need to log in before you can comment on or make changes to this bug.