Bug 1305107 - [GTK3] Java declaration view shows black text on black background
[GTK3] Java declaration view shows black text on black background
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: eclipse (Show other bugs)
DTS 4.0 RHEL 7
Unspecified Other
unspecified Severity unspecified
: alpha
: 4.1
Assigned To: Mat Booth
Václav Kadlčík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 11:30 EST by Eric Williams
Modified: 2016-05-31 04:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: devtoolset-4-eclipse-4.5.1-11.1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 04:41:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Declaration view does not show imageTypes members (135.54 KB, image/png)
2016-02-05 11:30 EST, Eric Williams
no flags Details

  None (edit)
Description Eric Williams 2016-02-05 11:30:45 EST
Created attachment 1121426 [details]
Declaration view does not show imageTypes members

Description of problem:
The declaration tab/view in the Java perspective shows black text on a black background. This makes it impossible to read anything beyond the type declaration.

Version-Release number of selected component (if applicable):
Eclipse Mars.1, DTS4.1, GTK3.14

How reproducible:
Always

Steps to Reproduce:
1. Open a Java file and the "Declaration" view
2. Place the cursor on a Java member/object/variable
3. Look in the declarations view: anything beyond the type declarations is invisible.

Actual results:
Text unreadable

Expected results:
Text readable

Additional info:
In the attached screenshot you can see the issue: the declaration view should show the members of "imageTypes", but doesn't. If you select the text in the declaration window you can see it, only because the selection background is white. The text color is black.
Comment 9 errata-xmlrpc 2016-05-31 04:41:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1145

Note You need to log in before you can comment on or make changes to this bug.