This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1305144 - ipa-python does not require its dependencies
ipa-python does not require its dependencies
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 14:56 EST by Scott Poore
Modified: 2016-11-04 01:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:51:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Poore 2016-02-05 14:56:16 EST
Description of problem:

It appears that ipa-python is missing some dependencies when installed by default.  From my test, I had to install the following additional rpms by hand:

python-krbV
python-dns
python-ldap

Version-Release number of selected component (if applicable):
ipa-python-4.2.0-15.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.  yum -y install ipa-python
2.  python -c "from ipapython import ipautil"


Actual results:

Fails to import until I install missing RPMs manually.


Expected results:

I would have thought that ipa-python would have required those rpms so they were installed as dependencies.

Additional info:



[root@vm3 ~]# python -c "from ipapython import ipautil"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 37, in <module>
    import krbV
ImportError: No module named krbV

[root@vm3 ~]# yum -y install python-krbV
...

[root@vm3 ~]# python -c "from ipapython import ipautil"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 40, in <module>
    from dns import resolver, rdatatype
ImportError: No module named dns

[root@vm3 ~]# yum -y install python-dns
...

[root@vm3 ~]# python -c "from ipapython import ipautil"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 46, in <module>
    from ipapython import config
  File "/usr/lib/python2.7/site-packages/ipapython/config.py", line 25, in <module>
    from ipapython.dn import DN
  File "/usr/lib/python2.7/site-packages/ipapython/dn.py", line 421, in <module>
    from ldap.dn import str2dn, dn2str
ImportError: No module named ldap.dn

[root@vm3 ~]# yum -y install python-ldap
...

[root@vm3 ~]# python -c "from ipapython import ipautil"
[root@vm3 ~]#
Comment 2 Petr Vobornik 2016-02-16 11:07:51 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5680
Comment 3 Petr Vobornik 2016-03-24 15:40:23 EDT
fixed upstream

master:
    d6f03da7535565daa936b79c445b835410333974 spec: Add missing dependencies to python*-ipalib package 

ipa-4-3:
    34ce42cc97fc7014a34179159e5a17690e4cdb34 spec: Add missing dependencies to python*-ipalib package
Comment 4 Mike McCune 2016-03-28 18:43:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Scott Poore 2016-06-22 18:04:21 EDT
Verified.

Version ::

ipa-python-compat-4.4.0-0.el7.1.alpha1

Results ::

[root@auto-hv-01-guest10 ~]# yum -y install ipa-python
...
Installed:
  ipa-python-compat.noarch 0:4.4.0-0.el7.1.alpha1                              

Dependency Installed:
  python-dns.noarch 0:1.12.0-2.20150617git465785f.el7                          
  python-ldap.x86_64 0:2.4.15-2.el7                                            
  python2-ipalib.noarch 0:4.4.0-0.el7.1.alpha1                                 

Complete!
[root@auto-hv-01-guest10 ~]# python -c "from ipapython import ipautil"
[root@auto-hv-01-guest10 ~]#
Comment 8 errata-xmlrpc 2016-11-04 01:51:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.