Bug 1305148 - [RFE] Programmatic view of scrub log
[RFE] Programmatic view of scrub log
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS (Show other bugs)
1.3.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.0
Assigned To: Kefu Chai
shylesh
Bara Ancincova
: FutureFeature
Depends On:
Blocks: 1322504
  Show dependency treegraph
 
Reported: 2016-02-05 15:04 EST by Neil Levine
Modified: 2017-07-30 11:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
.The `scrub` feature has been enhanced The OSD daemon now persists scrub results. In addition, a new `librados` API is provided to query the scrub results in detail.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:30:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 13505 None None None 2016-02-05 15:06 EST

  None (edit)
Description Neil Levine 2016-02-05 15:04:11 EST

    
Comment 4 Ken Dreyer (Red Hat) 2016-03-15 08:46:58 EDT
It's in master at least -> moving to POST to indicate that it's merged upstream and will be in v10.1.0.
Comment 7 Kefu Chai 2016-06-17 06:39:24 EDT
please see

- http://comments.gmane.org/gmane.comp.file-systems.ceph.devel/28103
- http://tracker.ceph.com/projects/ceph/wiki/Osd_-_Scrub_and_Repair
- http://pad.ceph.com/p/scrub_repair


in short:

The OSD now persists scrub results and provides a librados API to query results in detail.
Comment 10 shylesh 2016-08-04 11:39:12 EDT
All the targeted tests are done for this feature which covers 1. list-inconsistent-pg 2. list-inconsistent-obj 3. list-inconsistent-snapset.

hence marking this as verified.
Comment 12 errata-xmlrpc 2016-08-23 15:30:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755

Note You need to log in before you can comment on or make changes to this bug.