Bug 1305166 - [RFE] Allow oo-last-access to ignore user agents
[RFE] Allow oo-last-access to ignore user agents
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Timothy Williams
Wei Sun
:
Depends On:
Blocks: 1277547
  Show dependency treegraph
 
Reported: 2016-02-05 16:44 EST by Andy Grimm
Modified: 2016-11-07 22:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-04 16:34:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
WIP Patch (1.38 KB, patch)
2016-02-05 16:44 EST, Andy Grimm
no flags Details | Diff

  None (edit)
Description Andy Grimm 2016-02-05 16:44:08 EST
Created attachment 1121523 [details]
WIP Patch

As with unidling, it would be useful to be able to ignore certain user agent strings such as bots/spiders when deciding which applications to idle.

Ideally, a single configuration file could be used by both oo-last-access and restorer.php, since the user agent strings would be the same for both.

The attached patch illustrates the idea, but does not implement a configuration option or default location for the config file path yet.  It also matches against the entire apache log line rather than just the user agent string, so we may want to improve that (though if user agent strings are specific enough, it is unlikely that they would match other parts of the log line).  We also may want to sanitize the input before passing it into awk.

Note You need to log in before you can comment on or make changes to this bug.