Bug 1305171 - Flash message displayed twice while adding, deleting, editing schedules
Flash message displayed twice while adding, deleting, editing schedules
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.4.5
Assigned To: Harpreet Kataria
Nandini Chandra
ui:schedule:flash_msg
: ZStream
Depends On: 1269115
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 17:00 EST by Nandini Chandra
Modified: 2017-08-29 22:06 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.4.5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 10:17:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2016-02-05 17:00:36 EST
Description of problem:
----------------------


Version-Release number of selected component (if applicable):
---------------------------
5.4.5


How reproducible:
----------------
Always


Steps to Reproduce:
------------------
1.Navigate to the Cloud Intelligence->Reports->Schedules page
2.Add a new schedule,Edit, delete the schedule.


Actual results:
--------------
Flash message is displayed twice after each of the above operations is performed.


Expected results:
----------------
Flash message should be displayed once.


Additional info:
---------------
Comment 4 CFME Bot 2016-02-09 14:17:48 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=824fb6cde49129d3dfd52b96ff17c3bdbb9e2ff9

commit 824fb6cde49129d3dfd52b96ff17c3bdbb9e2ff9
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Feb 5 17:55:24 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Feb 5 17:55:24 2016 -0500

    Return to the schedule info instead of schedules list
    
    after adding, saving and cancelling schedule from
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1269115
    https://bugzilla.redhat.com/show_bug.cgi?id=1305171
    (cherry-picked from commit fb84c947e374bd7ec618d03fdfb6dc0950cc2c04)

 vmdb/app/controllers/report_controller/schedules.rb | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)
Comment 5 CFME Bot 2016-02-09 14:17:57 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ccf711b8c30d97bc19e9d9b8f99c535178e36cae

commit ccf711b8c30d97bc19e9d9b8f99c535178e36cae
Merge: fc5f57c 3604939
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Tue Feb 9 13:36:58 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Tue Feb 9 13:36:58 2016 -0500

    Merge branch '54z_pr_4879' into '5.4.z'
    
    Remove duplicated flash message from reporting schedule page
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1269115
    https://bugzilla.redhat.com/show_bug.cgi?id=1305171
    
    @dclarizi please review, clean patch was applied for changes in https://github.com/ManageIQ/manageiq/pull/4879
    
    See merge request !771

 vmdb/app/controllers/report_controller/schedules.rb | 4 +---
 vmdb/app/views/report/_schedule_list.html.haml      | 1 -
 2 files changed, 1 insertion(+), 4 deletions(-)
Comment 6 CFME Bot 2016-02-09 14:18:06 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=3604939e1131ae117232c95cab01872ceb02fe22

commit 3604939e1131ae117232c95cab01872ceb02fe22
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Feb 5 17:56:34 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Feb 5 17:56:34 2016 -0500

    Remove duplicated flash message from reporting schedule page
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1269115
    https://bugzilla.redhat.com/show_bug.cgi?id=1305171
    (cherry-picked from commit e3af61d40e5499d8af07e64a848d4069dd76705a)

 vmdb/app/views/report/_schedule_list.html.haml | 1 -
 1 file changed, 1 deletion(-)
Comment 8 Nandini Chandra 2016-03-21 14:38:38 EDT
Verified in 5.4.5.2
Comment 10 errata-xmlrpc 2016-03-29 10:17:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0171.html

Note You need to log in before you can comment on or make changes to this bug.