Bug 1305182 - Disable OOTB Alert deletion
Disable OOTB Alert deletion
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Dávid Halász
Matouš Mojžíš
ui:alert:usability
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 18:48 EST by Nandini Chandra
Modified: 2017-08-29 21:30 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:36:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2016-02-05 18:48:56 EST
Description of problem:
------------------------
It is currently possible to delete OOTB Alerts.Alert deletion should be disabled.


Version-Release number of selected component (if applicable):
---------------
5.4.5


How reproducible:
-----------------
Always


Steps to Reproduce:
------------------
1.Navigate to Control -> Explorer page.
2.Click 'All Alerts'. Select any Alert
3.Click 'Configuration', click 'Delete this Alert'


Actual results:
---------------
It is possible to delete OOTB Alerts.


Expected results:
----------------
Disable OOTB Alert deletion 


Additional info:
---------------
Comment 2 Nandini Chandra 2016-02-05 18:49:27 EST
This issue also occurs in 5.5.
Comment 4 Dávid Halász 2016-02-17 10:17:04 EST
Is there any way to determine if an alert is OOTB or not?
Comment 6 CFME Bot 2016-04-19 08:40:41 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/0c613ef49d36733e84bdcff32f2506d8339c7721

commit 0c613ef49d36733e84bdcff32f2506d8339c7721
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Mon Apr 18 18:58:07 2016 +0200
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Mon Apr 18 22:15:41 2016 +0200

    Return a flash message if the user tries to delete an OOTB alert
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1305182

 app/controllers/miq_policy_controller/alerts.rb    |  4 ++++
 .../miq_policy_controller/alerts_spec.rb           | 26 ++++++++++++++++++++--
 2 files changed, 28 insertions(+), 2 deletions(-)
Comment 7 Matouš Mojžíš 2016-04-27 05:20:20 EDT
How to find out which alerts are OOTB and which are not?
Comment 8 Nandini Chandra 2016-04-27 11:59:12 EDT
All the alerts listed on the Control -> Explorer page would be considered as OOTB.
Comment 9 Nandini Chandra 2016-04-27 12:00:36 EDT
Verified that 1)a flash message is displayed when a user tries to delete OOTB alerts  and 2)OOTB alerts cannot be disabled with the fix.

Verified in 5.6.0.4
Comment 11 errata-xmlrpc 2016-06-29 11:36:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.