Bug 130519 - X hangs with garbage on screen with DRI, IBM Thinkpad T40 2379-D3U, Radeon Mobility 7500
X hangs with garbage on screen with DRI, IBM Thinkpad T40 2379-D3U, Radeon Mo...
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-08-20 19:14 EDT by darkness
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-21 15:21:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg output after X starts (11.47 KB, text/plain)
2004-08-20 19:30 EDT, darkness
no flags Details
/var/log/Xorg.0.log after X has started (and the screen is corrupted) (33.97 KB, text/plain)
2004-08-20 19:32 EDT, darkness
no flags Details
/etc/X11/xorg.conf (3.42 KB, text/plain)
2004-08-20 19:33 EDT, darkness
no flags Details

  None (edit)
Description darkness 2004-08-20 19:14:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)

Description of problem:
When machine boots into runlevel 5, and X starts, the screen is filled
with garbage.  There is a mouse cursor, which changes to an hourglass
then to the "I" cursor since the cursor starts out right over what I
presume is the login text box.  You can move the cursor around the
screen and it changes based on whether it's in that text box or not. 
If you try to change to VC 1 (Ctrl-Alt-F1) the machine locks up: can't
ping it, can't move the mouse cursor, can't use Alt-Sysrq-B to reboot.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install FC2
2. Let it boot in runlevel 5

Actual Results:  Garbage on screen and no way out, see description

Expected Results:  The FC2 login screen and a usable X, with the
ability to change into a text VC.

Additional info:

This machine was working fine on FC1 before I started having some
hanging-on-resume problems randomly one day, and decided to reformat
and go to FC2.  Before installing FC2 I did update my BIOS and
embedded controller.  If there are doubts about my hardware I'll go
back and install FC1 to see if DRI works.

This is my second install of FC2 on this laptop, having made quite a
mess of the first install by doing things like:
- Trying the kernel in the "development" directory on mirrors (is this
called "rawhide" still?)
- Trying the xorg-x11 from "development"
- Compiling my own kernel with newer ACPI and APIC turned on (which I
now believe to be unrelated to this problem; see below)

Additional things I've tried:
- Compiling radeonfb into the kernel, and breaking intel-agp and
agpgart out into modules
- Disabling the vnc module in the X server, since I read a few bug
reports that seemed to point a finger at it
- Using the xorg.conf that the installer generated as well as one
constructed from the output of X -configure
- ACPI and APM; both exhibit the problem
- service stop cpuspeed and locking the CPU at its max frequency,
since I read a bug report where someone was having a problem with X
locking up when CPU speed changed

Finally, disabling DRI (commenting out Load "dri" or Option "NoAccel"
in the driver) makes everything work fine.

Tried kernel 2.6.7-1.494.2.2 and now 2.6.8-1.521.  I should be up to
date as of 2004-08-20 on all errata.  I believe I had this same
problem with firstboot and/or rhgb when I first installed FC2 under
the kernel and xorg-x11 versions on the CD.  I will go back and
reinstall FC2, or revert to earlier versions of whatever packages, to
test this problem if requested.

I'm also happy to file this upstream, except I don't exactly know who
to file with: xorg-x11 or the kernel.
Comment 1 darkness 2004-08-20 19:30:55 EDT
Created attachment 102944 [details]
dmesg output after X starts
Comment 2 darkness 2004-08-20 19:32:02 EDT
Created attachment 102945 [details]
/var/log/Xorg.0.log after X has started (and the screen is corrupted)
Comment 3 darkness 2004-08-20 19:33:51 EDT
Created attachment 102946 [details]

This file is an amalgam of the installer's xorg.conf and the xorg.conf
generated by X -configure.
Comment 4 darkness 2004-08-21 15:21:22 EDT
OK, I just did a fresh install of FC1 for a test, and it doesn't work
out of the box, like I believe it did previously.  I'm going to play
with it a bit, but until I eliminate hardware (naturally, when I was
so sure my hardware didn't magically go from working to broken
overnight) please don't put any effort into this bug.

Note You need to log in before you can comment on or make changes to this bug.