Bug 1305202 - [Docs] [Director] -bash: /etc/ahc-tools/ahc-tools.conf: No such file or directory
[Docs] [Director] -bash: /etc/ahc-tools/ahc-tools.conf: No such file or direc...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Dan Macpherson
RHOS Documentation Team
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 21:32 EST by Shinobu KINJO
Modified: 2016-03-15 23:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-15 23:14:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shinobu KINJO 2016-02-05 21:32:29 EST
Description of problem:

Title: Red Hat Enterprise Linux OpenStack Platform 7 Director Installation and Usage
Section: 6.3.3. Automatically Tagging Nodes with Automated Health Check (AHC) Tools
Page: 58
Description:

As described in page 58, when I did:

 $ sudo yum install -y ahc-tools
 $ sudo -i
 # sed 's/\[discoverd/\[ironic/' /etc/ironic-discoverd/discoverd.conf > /etc/ahc-tools/ahc-tools.conf

it ended up with:

 -bash: /etc/ahc-tools/ahc-tools.conf: No such file or directory

Because of -;

 # ls /etc/ahc-tools/
 ls: cannot access /etc/ahc-tools/: No such file or directory

I don't see any directory creation process in the guide.
Should that directory be created by hand or package - ahc-tools?

Mmm...

Anyhow thank you for your advice in advance.

Rgds,
Shinobu

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Andrew Dahms 2016-02-07 21:59:27 EST
Assigning to Dan for review.
Comment 3 Dan Macpherson 2016-02-08 21:57:26 EST
Looks like it's missing the following command:

# mkdir /etc/ahc-tools

Adding this to doc
Comment 7 Dan Macpherson 2016-03-15 23:14:44 EDT
No response in over a month and changes are live on the portal now. Closing this BZ down.

If further changes are required, please feel free to reopen this BZ.

Note You need to log in before you can comment on or make changes to this bug.