Bug 1305210 - Wrong error info when import non-existent disk image from virt-manager GUI
Wrong error info when import non-existent disk image from virt-manager GUI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.3
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On: 1305209
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-06 01:24 EST by tingting zheng
Modified: 2016-11-03 22:01 EDT (History)
9 users (show)

See Also:
Fixed In Version: virt-manager-1.4.0-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1305209
Environment:
Last Closed: 2016-11-03 22:01:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2016-02-06 01:24:18 EST
The bug can also be reprodued on rhel7,so clone this bug.
+++ This bug was initially created as a clone of Bug #1305209 +++

Description:
Wrong error info when import non-existent disk image from virt-manager GUI

Version:
virt-manager-0.9.0-31.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Lauch virt-manager GUI.

2.Create a new guest,choose "Import existing disk image",click "Forward",input non-existent disk image path in input field "Provide the existing storage path",eg:sdfsfd,error shows as below:
Size must be specified for non-existent volume path '/root/sdfsfd

Actual results:
As description.

Expected results:
No input field in virt-manager GUI for input size,the error info is confusing for users,changed to something like "The volume path doesn't exist".

Additional info:
It can also be reproduced on rhel7.
Comment 2 Pavel Hrdina 2016-06-07 13:51:35 EDT
Upstream commit:

commit 7280dcf7dfd2f3b55a342c1ccdd4c5447ddc6045
Author: Pavel Hrdina <phrdina@redhat.com>
Date:   Tue Jun 7 13:55:58 2016 +0200

    create: report an error if storage doesn't exists for import installation
Comment 4 XiaoyunHu 2016-06-22 23:23:32 EDT
I can reproduce this bug with package:
virt-manager-1.2.8-1.el7.noarch

Steps are the same as description above.

Then try to verify with new build:
virt-manager-1.4.0-1.el7.noarch

Steps:
1.Lauch virt-manager .
#virt-manager

2.Create a new guest,choose "Import existing disk image",click "Forward",input non-existent disk image path in input field "Provide the existing storage path",eg:sdfsfd

Results:
After step2, An input error "The import path must point to an existing storage" pops up.

According to the result above in the latest version of virt-manager, move this bug from ON_QA to VERIFIED.
Comment 6 errata-xmlrpc 2016-11-03 22:01:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2269.html

Note You need to log in before you can comment on or make changes to this bug.