Bug 1305220 - openscad: FTBFS in rawhide
openscad: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openscad (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
: 1323402 (view as bug list)
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-06 01:30 EST by Fedora Release Engineering
Modified: 2016-04-14 05:18 EDT (History)
7 users (show)

See Also:
Fixed In Version: openscad-2015.03.2-6.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 17:33:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (355.45 KB, text/plain)
2016-02-06 01:30 EST, Fedora Release Engineering
no flags Details
root.log (124.43 KB, text/plain)
2016-02-06 01:30 EST, Fedora Release Engineering
no flags Details
state.log (641 bytes, text/plain)
2016-02-06 01:30 EST, Fedora Release Engineering
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 70437 None None None 2016-04-04 07:25 EDT

  None (edit)
Description Fedora Release Engineering 2016-02-06 01:30:23 EST
Your package openscad failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12800996

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-06 01:30:27 EST
Created attachment 1121592 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-06 01:30:29 EST
Created attachment 1121593 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-06 01:30:30 EST
Created attachment 1121594 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:25:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Yaakov Selkowitz 2016-03-07 17:16:45 EST
Reported upstream: https://github.com/openscad/openscad/issues/1575
Comment 6 Jason Merrill 2016-03-28 23:44:21 EDT
Reduced:

#include <type_traits>
#include <utility>

template <class T> struct A;
template <class T> struct B;

template <class T> struct A
{
  A(A&&) = default;
  A(const B<T> &);
};

template <class T> struct B
{
  std::pair<A<T>,int> a;
  B(B&&) = default;
};

bool b = std::is_move_constructible<A<int> >::value;
Comment 7 Yaakov Selkowitz 2016-03-29 00:09:53 EDT
(In reply to Jason Merrill from comment #6)
> Reduced:

That compiles fine with g++ 5.3 (with -std=c++11) but not with 6.0.  PR?
Comment 8 Miro Hrončok 2016-03-29 06:48:06 EDT
Shouldn't wee send that upstream?

https://github.com/openscad/openscad/issues/1575
Comment 9 Jonathan Wakely 2016-04-04 07:23:33 EDT
*** Bug 1323402 has been marked as a duplicate of this bug. ***
Comment 10 Miro Hrončok 2016-04-04 07:53:48 EDT
What is the contingency plan if gcc doesn't get fixed?

I don't want to end up without OpenSCAD in F24.
Comment 11 Jonathan Wakely 2016-04-05 08:11:13 EDT
GCC has been fixed.
Comment 12 Jonathan Wakely 2016-04-05 08:11:37 EDT
... upstream. Not in Fedora yet.
Comment 13 Miro Hrončok 2016-04-05 08:55:07 EDT
Awesome, thanks. Shall I create a bug for gcc component?
Comment 14 Miro Hrončok 2016-04-09 21:25:39 EDT
The gcc issue is fixed in gcc-6.0.0-0.20.fc24. I've submitted a buidroot override and will build openscad once it's in effect.

Already successfully built in mock and building in Koji for rawhide.
Comment 15 Upstream Release Monitoring 2016-04-09 22:21:41 EDT
churchyard's openscad-2015.03.2-6.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=752981
Comment 16 Fedora Update System 2016-04-10 07:05:30 EDT
openscad-2015.03.2-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c59697e8db
Comment 17 Fedora Update System 2016-04-11 06:19:47 EDT
openscad-2015.03.2-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c59697e8db
Comment 18 Fedora Update System 2016-04-13 17:33:39 EDT
openscad-2015.03.2-6.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Miro Hrončok 2016-04-14 05:18:34 EDT
Thank you all for help.

Note You need to log in before you can comment on or make changes to this bug.