Bug 1305256 - GlusterD restart, starting the bricks when server quorum not met
GlusterD restart, starting the bricks when server quorum not met
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.7
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Atin Mukherjee
: Triaged
Depends On: 1298068 1298439
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-06 08:14 EST by Atin Mukherjee
Modified: 2016-04-19 03:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1298439
Environment:
Last Closed: 2016-04-19 03:25:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2016-02-06 08:14:23 EST
+++ This bug was initially created as a clone of Bug #1298439 +++

+++ This bug was initially created as a clone of Bug #1298068 +++

Description of problem:
=======================
Had 5 node cluster (n1, n2, n3, n4 & n5 ) with one distributed volume with server quorum enabled  and stopped glusterd in 3 nodes (n3,n4 and n5) and checked the volume status in n1 node, the bricks were offline and restarted the glusterd on that node (n1) and checked the volume status again, this time it bricks are in online.

Version-Release number of selected component (if applicable):
==============================================================
glusterfs-3.7.5-15


How reproducible:
=================
Always

Steps to Reproduce:
===================
1. Have 5 node cluster with one distributed volume
2. Enable the server quorum
3. Bring down 3 nodes ( Eg , n3, n4 and n5)
4. Check the volume status in node-1 (n1) // bricks will be in offline state
5. Restart glusterd on node-1
6. Check the volume status // bricks will be in online state

Actual results:
===============
bricks are in online when server quorum not met


Expected results:
=================
Bricks should be in offline state when server quorum not met

--- Additional comment from Vijay Bellur on 2016-01-14 00:52:58 EST ---

REVIEW: http://review.gluster.org/13236 (glusterd: check quorum on restart bricks) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-26 10:02:08 EST ---

REVIEW: http://review.gluster.org/13236 (glusterd: check quorum on restart bricks) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-02 22:29:47 EST ---

REVIEW: http://review.gluster.org/13236 (glusterd: check quorum on restart bricks) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-05 10:26:46 EST ---

COMMIT: http://review.gluster.org/13236 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 2fe4f758f4f32151ef22d644c4de1e58a508fc3e
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Jan 14 11:11:45 2016 +0530

    glusterd: check quorum on restart bricks
    
    While spawning bricks on a glusterd restart the quorum should be checked and
    brick shouldn't be started if the volume doesn't meet quorum.
    
    Change-Id: I21bf9055bdf38c53c81138cc204ba05a9ff6444f
    BUG: 1298439
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/13236
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 1 Vijay Bellur 2016-02-06 08:15:14 EST
REVIEW: http://review.gluster.org/13390 (glusterd: check quorum on restart bricks) posted (#1) for review on release-3.7 by Atin Mukherjee (amukherj@redhat.com)
Comment 2 Vijay Bellur 2016-02-17 04:50:57 EST
COMMIT: http://review.gluster.org/13390 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit d132a4704d9b1df55c4c4e56a8389078b80897bd
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Jan 14 11:11:45 2016 +0530

    glusterd: check quorum on restart bricks
    
    Backport of http://review.gluster.org/#/c/13236/
    
    While spawning bricks on a glusterd restart the quorum should be checked and
    brick shouldn't be started if the volume doesn't meet quorum.
    
    Change-Id: I21bf9055bdf38c53c81138cc204ba05a9ff6444f
    BUG: 1305256
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/13236
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-on: http://review.gluster.org/13390
    Reviewed-by: Gaurav Kumar Garg <ggarg@redhat.com>
Comment 3 Mike McCune 2016-03-28 18:15:42 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Kaushal 2016-04-19 03:25:16 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.