Bug 130526 - bogus and misleading error message from %pre script in dev package
bogus and misleading error message from %pre script in dev package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: MAKEDEV (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On: 108757
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 20:23 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.12.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 11:25:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-08-20 20:23:10 EDT
Description of problem:

With tmpfs mounted on /dev an attempt to reinstall 'dev' package
produces:

Cannot install the dev package: mounted devfs detected.
error: %pre(dev-3.8.3-1) scriptlet failed, exit status 1

If there was no devfs ever on a machine this leaves a victim
with a head scratcher as obvioulsy there is no devfs in sight
anywhere (it turns out that this an unexpected and incomplete
udev courtesy of a messed up mkinitrd).  It would be good to
mention some other possibilieties in that message.
Comment 1 Andy Green 2004-09-02 06:30:45 EDT
Me  too... latest rawhide killed abaility tolog into X as anyone but
root.  Saw dev package failed to update with this error.  Booted with
init=bash to solve mount problem but even without it mounted still get
error.....  Arggghh!!!
Comment 2 Michael Young 2004-09-03 10:49:17 EDT
Try updating udev and initscripts to solve the X problem.
Comment 3 Nalin Dahyabhai 2004-09-14 11:25:15 EDT
As of MAKEDEV 3.12.1, the dev package is no more, so I guess the
question of how to phrase the error message becomes moot.

Note You need to log in before you can comment on or make changes to this bug.