Bug 1305264 - Expand a ceph cluster from installer API
Expand a ceph cluster from installer API
Status: CLOSED ERRATA
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer (Show other bugs)
2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2
Assigned To: Andrew Schoen
Rachana Patel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-06 09:26 EST by Gregory Meno
Modified: 2016-08-23 15:46 EDT (History)
9 users (show)

See Also:
Fixed In Version: ceph-installer-1.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:46:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Meno 2016-02-06 09:26:11 EST
Description of problem:

Ceph cluster expansion:

adding Node with roles

Configure Osds for disks in an existing OSD Node
Expectation: OSD packages are installed

Journal size should also be taken care here, when a node or OSDs are getting added

API defined here https://github.com/ceph/mariner-installer/#apiosdconfigure

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Gregory Meno 2016-02-06 09:28:28 EST
Dusmant what does "Ceph cluster expansion: adding Node with roles" mean in this context?
Comment 4 Mike McCune 2016-03-28 18:16:42 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 12 Rachana Patel 2016-08-07 11:16:13 EDT
verified with

ceph-ansible-1.0.5-23.el7scon.noarch
ceph-installer-1.0.12-3.el7scon.noarch


- able to add new MON node
- able to add new OSD node and OSDs to existing cluster
working as expected hence moving to verified
Comment 14 errata-xmlrpc 2016-08-23 15:46:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754

Note You need to log in before you can comment on or make changes to this bug.