Bug 1305278 - In KDE plasma incorrect recording device is selected by default
In KDE plasma incorrect recording device is selected by default
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-06 10:51 EST by Kambiz Aghaiepour
Modified: 2016-12-20 13:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 13:29:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
default pavucontrol when video conference is started (326.24 KB, image/png)
2016-02-06 10:51 EST, Kambiz Aghaiepour
no flags Details
Manually changing the audio source and things work (348.36 KB, image/png)
2016-02-06 10:52 EST, Kambiz Aghaiepour
no flags Details

  None (edit)
Description Kambiz Aghaiepour 2016-02-06 10:51:52 EST
Created attachment 1121684 [details]
default pavucontrol when video conference is started

Description of problem:

I am running Fedora23 on a Precision Dell T1700 with integrated audio:

[kambiz@vorlon ]$ sudo lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)

I also have a USB based Logitech C270 WebCam attached to the system.  I run KDE plasma, and though I can use the webcam for audio input (recording), applications never default to using the webcam microphone and I have to run pavucontrol to change the audio recording source.

I'm attaching screenshots to illustrate.

How reproducible:

I will use bluejeans as an example (though all applications behave the same way)

Steps to Reproduce:
1. Go to system settings
2. select multimedia 
3. choose audio and video on the left side bar 
4. Under the audio recording section for:
    communication
    recording
    control
  select the "Built-n Audio Analog Stereo" input device and select "Defer" at the bottom to change the order of preference. (The "Webcam C270 Analog Mono" device is also listed and is now first in the list)

5. connect to some video conferencing type service (bluejeans, viber, google hangouts, whatever).

6. Remote parties will not be able to hear you.
7. Launch "pavucontrol"
8. Note that the selected audio source for the application requiring recording is the Built-in Audio Analog source.
9. Manually change it in the "pavucontrol" application and now recording works.

Sometimes the initial recording source is correctly selected as the USB webcam, but after the initial usage, after a couple of seconds it changes to the built-in source and has to be manually changed via pavucontrol.  Once it is changed, it does persist during the duration of the application.  However, if one leaves the video conference and connects to a new conference, the same problem returns requiring manually changing the audio recording source.
Comment 1 Kambiz Aghaiepour 2016-02-06 10:52 EST
Created attachment 1121685 [details]
Manually changing the audio source and things work
Comment 2 Kambiz Aghaiepour 2016-02-08 10:13:00 EST
One more update on this,  when I join a conference call, and I have "pavucontrol" open, it clearly lists the "Webcam C270 Analog Mono" as the recording source, until I start speaking ("testing 1 2 3") at which point it automatically switches to the built in source.  Manually switching it back to the C270 source works, and the setting stays on the C270 for the duration of the call.
Comment 3 Rex Dieter 2016-02-08 10:31:03 EST
Try setting device priorities under
systemsettings5 -> multimedia -> audio&video -> device preference(tab)

??
Comment 4 Kambiz Aghaiepour 2016-02-08 10:33:48 EST
The device priorities were set already but the behavior was still not as I would expect.  However, my immediate problem is solved by changing the profile settings in the pavucontrol so that for the build in audio, I am using "output only" as opposed to duplex.  In this way pulseaudio only uses the build in card for output only. I'm really not sure if this is a bug or if this is expected behavior, but just in case someone else runs into this, note that it was under the configuration tab of pavucontrol that I was able to resolve the issue.
Comment 5 Fedora End Of Life 2016-11-24 10:25:29 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2016-12-20 13:29:25 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.