This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1305279 - RFE: Please provide option RandomizedDelaySec= to systemd timer
RFE: Please provide option RandomizedDelaySec= to systemd timer
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: systemd-maint
Branislav Blaškovič
Maxim Svistunov
: FutureFeature
Depends On: 1303552
Blocks: 1203710 1289485 1313485
  Show dependency treegraph
 
Reported: 2016-02-06 11:29 EST by Nilesh Parmar
Modified: 2017-03-06 12:43 EST (History)
15 users (show)

See Also:
Fixed In Version: systemd-219-21.el7
Doc Type: Enhancement
Doc Text:
New *systemd* option: `RandomizedDelaySec` This update introduces the `RandomizedDelaySec` option for *systemd* timers, which schedules an event to occur later by a random number of seconds. For example, setting the option to 10 will postpone the event by a random number of seconds between 0 and 10. The new option is useful for spreading workload over a longer time period to avoid several events executing at the same time.
Story Points: ---
Clone Of: 1303552
Environment:
Last Closed: 2016-11-03 20:51:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nilesh Parmar 2016-02-06 11:29:34 EST
+++ This bug was initially created as a clone of Bug #1303552 +++

Description of problem:

systemd 228 contains an option RandomSec= for systemd timer unit files.

Please backport this feature to Fedora 23.

Please see also bug #1074951 .


Version-Release number of selected component (if applicable):
systemd-222-12.fc23.x86_64

--- Additional comment from Jan Synacek on 2016-02-01 07:20:58 EST ---

Backport 744c7693751830149ae78fdaf95c6c6f99d59f07 and 6f5d79986a9c98b9cacc83f865fed957e4e6e4e6.

--- Additional comment from Fedora Update System on 2016-02-01 09:51:26 EST ---

systemd-222-14.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d3fc0f9415

--- Additional comment from Jan Synacek on 2016-02-01 09:52:25 EST ---

Note that the real option name is "RandomizedDelaySec=".

--- Additional comment from Fedora Update System on 2016-02-01 21:26:46 EST ---

systemd-222-14.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d3fc0f9415

--- Additional comment from Fedora Update System on 2016-02-04 18:23:06 EST ---

systemd-222-14.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 errata-xmlrpc 2016-11-03 20:51:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2216.html

Note You need to log in before you can comment on or make changes to this bug.