Bug 1305282 - Errors in kturtle.mo
Errors in kturtle.mo
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kde-l10n (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 1305280 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-06 12:21 EST by Pierre Juhen
Modified: 2016-02-06 17:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-06 16:51:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Juhen 2016-02-06 12:21:00 EST
Description of problem:

Kturtle French translation is corrupted.

Version-Release number of selected component (if applicable):
kde-l10n-15.08.3-2.fc23.noarch
kde-l10n-fr-15.08.3-2.fc23.noarch

Additional info:

msgunfmt on /usr/share/locale/fr/LC_MESSAGES/kturtle.mo shows it's corrupted.
Rebuilding kturtle.mo from source kturtle.po using msgfmt corrects the problem.
I suspect kde-l10n needs a full rebuild after tool changes.
Comment 1 Rex Dieter 2016-02-06 12:40:34 EST
*** Bug 1305280 has been marked as a duplicate of this bug. ***
Comment 2 Rex Dieter 2016-02-06 13:52:26 EST
> msgunfmt on /usr/share/locale/fr/LC_MESSAGES/kturtle.mo shows it's corrupted.

How exactly does it show corruption for you?

It seems to be ok as far as I can tell.
Comment 3 Pierre Juhen 2016-02-06 16:51:06 EST
I had the problem on 2 PC. 

That's why I thought the problem came from the distribution.

On one, msgunfmt showed that the logic msgid / mgstr was broken, unterminated strings...

After your message, I did a dnf reinstall and it became OK.

I went back on the other PC, and the file was OK, but there was an error (not explained) on selinux attibutes.

So two differents errors, same symptoms, and an unjustified bug report.

I close It

Sorry...
Comment 4 Rex Dieter 2016-02-06 17:15:24 EST
thanks for double-checking

Note You need to log in before you can comment on or make changes to this bug.