Bug 1305310 - Improvements to the cmake package
Improvements to the cmake package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cmake (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-06 17:53 EST by roidelapluie
Modified: 2016-02-07 18:28 EST (History)
5 users (show)

See Also:
Fixed In Version: cmake-3.4.3-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-07 18:28:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix tests under el7 (2.63 KB, patch)
2016-02-06 17:53 EST, roidelapluie
no flags Details | Diff

  None (edit)
Description roidelapluie 2016-02-06 17:53:32 EST
Created attachment 1121814 [details]
Patch to fix tests under el7

Description of problem:

I would like to bring some improvements to the cmake spec file that would allow us to rebuild it in EL7.

1. The package provides a --without gui flag. However, that flag does not work because of a installed but not packaged file:

error: Installed (but unpackaged) file(s) found:
   /usr/share/man/man1/cmake-gui.1.gz


The solution I have used is to change the section of the %{_mandir}/man1/cmake-gui.1.gz file.




2. There are 2 requirements missing:
BuildRequires:  gcc-c++                                                  
BuildRequires:  make


3. A patch is needed to fix the tests:

332:   Expected stderr to match:
332: 
332:    expect-err> Error message was: ([Cc]ould *n.t resolve host:? '?-no-site-'?|The requested URL returned error:.*)
332:    expect-err>    Problems when submitting via FTP
332: 
332:   Actual stderr:
332: 
332:    actual-err>    Error when uploading file: /home/bob/rpmbuild/BUILD/cmake-3.4.3/build/Tests/RunCMake/ctest_submit/FailDrop-ftp-build/Testing/20160206-1516/Configure.xml
332:    actual-err>    Error message was: Could not resolve host: -no-site-; Name or service not known
332:    actual-err>    Problems when submitting via FTP


The patch is attached
Comment 1 roidelapluie 2016-02-06 17:57:02 EST
The version of the package I started from is 3.4.3-2.
Comment 2 Rex Dieter 2016-02-07 15:25:16 EST
You may be interested in the cmake3 pkg available from epel-7 repo
Comment 3 Orion Poplawski 2016-02-07 18:28:10 EST
Well, while there is the beginning of a cmake3 review (with a couple options) here: https://bugzilla.redhat.com/show_bug.cgi?id=1290199 - it is not yet in EPEL7.

I've filed https://public.kitware.com/Bug/view.php?id=15957 about cmake-gui.1 getting installed, but have worked around it in 3.4.3-3.

I've filed https://public.kitware.com/Bug/view.php?id=15958 for the ctest failure.  I did not see it in my testing so I did not yet apply it.

Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.