Bug 1305330 - Disable high availability option for hosted engine VM
Disable high availability option for hosted engine VM
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.3
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.6
: 3.6.6
Assigned To: Phillip Bailey
Artyom
: Triaged
: 1305045 (view as bug list)
Depends On:
Blocks: 1290478
  Show dependency treegraph
 
Reported: 2016-02-07 03:46 EST by Doron Fediuck
Modified: 2016-05-30 06:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the high availability option could be enabled in the webadmin UI and via the REST API when using a hosted engine setup. Since hosted engine setups use a separate high availability mechanism, this should not have been the case. Now, on hosted engine setups, the high availability option is disabled in the UI and an error will be generated when attempting to enable it via the REST API.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-30 06:52:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: exception+
mgoldboi: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53603 master MERGED core: Disabled ability to make VM HA on hosted engine 2016-02-23 14:09 EST
oVirt gerrit 53860 ovirt-engine-3.6 MERGED core: Disabled ability to make VM HA on hosted engine 2016-04-06 03:12 EDT

  None (edit)
Description Doron Fediuck 2016-02-07 03:46:51 EST
Since HE uses a separate HA mechanism, the existing HA option should
not be available fot this VM.
The UI option should be grayed out, and a can-do-action additional
condition should be added to prevent utilizing it from the REST API.
Comment 1 Roy Golan 2016-02-17 06:45:25 EST
*** Bug 1305045 has been marked as a duplicate of this bug. ***
Comment 2 Mike McCune 2016-03-28 19:17:33 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 3 Sandro Bonazzola 2016-04-11 10:46:19 EDT
This bug is targeted to 3.6.5 but referenced patches are not included in 3.6.5.3 code. please re-target to 3.6.6
Comment 4 Phillip Bailey 2016-04-18 09:41:54 EDT
Re-target completed by Roy.
Comment 5 Artyom 2016-05-01 04:10:09 EDT
Verified on rhevm-3.6.6-0.1.el6.noarch
Message: "VM can not be set highly available when hosted engine is used"

Note You need to log in before you can comment on or make changes to this bug.