Bug 1305339 - [RFE] - Allow addition of boot kernel params arguments
[RFE] - Allow addition of boot kernel params arguments
Status: CLOSED CURRENTRELEASE
Product: ovirt-node
Classification: oVirt
Component: RFEs (Show other bugs)
3.6
x86_64 Linux
medium Severity medium (vote)
: ovirt-4.0.0-alpha
: 4.0
Assigned To: Fabian Deutsch
Wei Wang
: FutureFeature, TestOnly
Depends On:
Blocks: ovirt-node-ng 1351887
  Show dependency treegraph
 
Reported: 2016-02-07 05:15 EST by Michael Burman
Modified: 2016-07-05 03:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:47:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
gklein: testing_plan_complete-
mgoldboi: planning_ack+
fdeutsch: devel_ack+
ycui: testing_ack+


Attachments (Terms of Use)
kickstart file (621 bytes, text/plain)
2016-04-26 03:15 EDT, Wei Wang
no flags Details

  None (edit)
Description Michael Burman 2016-02-07 05:15:45 EST
Description of problem:
[RFE] - Add boot kernel params arguments and an option to enable them via TUI

Today the raw arguments are not exposed in the TUI anywhere, and can be appended via the syslinux menu as a work around. 

It will be good to expose boot kernel params, such as 'intel_iommu=on' in the TUI in order to use SR-IOV feature for example on 3.6 and an option to enable them via the TUI.
Comment 1 Michal Skrivanek 2016-02-07 07:43:01 EST
see also related bug 1301104
Comment 3 Ying Cui 2016-03-24 02:56:45 EDT
QE will verify this bug according to _comment 2_ with grubby tool to persist changes to the grub.
Comment 4 Michal Skrivanek 2016-03-24 11:58:01 EDT
Fabian, shouldn't this be targetted to 3.6 actually? We do need kernel arguments for VFIO passthrough and since this is mostly just documentation and testing it shouldn't be a big deal to support it on 7.2, right?
Comment 5 Fabian Deutsch 2016-03-29 07:11:10 EDT
We have a documented way of how to add kernel arguments to vintage RHEV-H:
https://access.redhat.com/solutions/294393

To me this looks sufficient.
Comment 6 Michal Skrivanek 2016-03-29 07:44:58 EDT
It is sufficient indeed. Ok, so in 3.6 it's the "old" manual way described there, in 4.0 it's the grubby way
Thank you for clarification
Comment 7 Wei Wang 2016-04-26 03:15 EDT
Created attachment 1150752 [details]
kickstart file
Comment 8 Wei Wang 2016-04-26 03:16:30 EDT
Test the grubby way to add boot kernel arguments with ovirt-node-ng-installer-ovirt-4.0-2016042500.iso, the issue is verified successfully.

Steps:
1. Install ovirt-node 4.0 in a machine with kickstart file
2. Login, then input CLI according to https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/System_Administrators_Guide/sec-Making_Persistent_Changes_to_a_GRUB_2_Menu_Using_the_grubby_Tool.html
e.g : 
     grubby --info=ALL
     grubby --remove-args="arg1 arg2" --args="argA argB" --update-kernel /boot/kernel-name
     grubby --info /boot/kernel-name
3. reboot to check the arguments are effected.

Result:
The added arguments are effected by using grubby way. 
     
So this bug is verified now, change the bug status to VERIFIED.
Comment 9 Sandro Bonazzola 2016-07-05 03:47:07 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.