Bug 1305356 - dnf groupinstall does not install packages, only marks them
dnf groupinstall does not install packages, only marks them
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-07 09:21 EST by cornel panceac
Modified: 2016-03-26 13:58 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-1.1.7-2.fc23 dnf-1.1.7-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 13:58:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf log (6.88 KB, text/plain)
2016-02-07 09:21 EST, cornel panceac
no flags Details

  None (edit)
Description cornel panceac 2016-02-07 09:21:16 EST
Created attachment 1121912 [details]
dnf log

Description of problem:
On a freshly installed and updated F23 x64 i tried:

# dnf groupinstall MATE\ Compiz MAte\ Applications Sound\ and\ Video Office/Productivity Games\ and\ Entertainment LibreOffice 

The outcome was a list of one group and several packages proposed to be marked as installed. But they were not actually installed.

See attachment for details.

Version-Release number of selected component (if applicable):
dnf-1.1.6-2.fc23.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jaroslav Mracek 2016-02-08 08:21:41 EST
Please could you try to compare list of mandatory packages for a group (dnf group info <group>) with installed packages (dnf repoquery --installed). If all mandatory packages of the group are installed, dnf only marks the group as installed, because there in nothing to install. Thank you very much for your feedback.
Comment 2 Rex Dieter 2016-02-08 09:43:47 EST
OK, interesting, at least some of these groups of *zero* mandatory packages, including:
Games and Entertainment
Office/Productivity
Sound and Video

Libreoffice, Mate Compiz, Mate Applications all include some without type= specified, do those count as mandatory (or just default)?
Comment 3 cornel panceac 2016-02-09 02:21:25 EST
Hi, this is not easy to do because i've already installed those packages. On the other hand, having groups with no mandatory packages makes no sense to me. And the question reains, why some packages are 'marked' as installed but not actualy installed.
Comment 4 Honza Silhan 2016-02-18 08:15:34 EST
(In reply to Rex Dieter from comment #2)
> Libreoffice, Mate Compiz, Mate Applications all include some without type=
> specified, do those count as mandatory (or just default)?

yes, non typed packagereq tags are considered as mandatory type.
mandatory type -> always install or fail
default type -> always install, if some deps cannot be satisfied ignore them
optional type -> install with ``--with-optional` switch, if some deps cannot be satisfied ignore them

From "Mate Applications" I get all these packages into transaction. "Sound and Video" contain just optional packages (don't know the reason).

I believe that bug report is about skipping the default packages that are not installed, which deps cannot be satisfied but still shown as marked as installed. This issue is fixed in this PR [1].

[1] https://github.com/rpm-software-management/dnf/pull/444
Comment 5 Fedora Update System 2016-02-25 08:53:37 EST
dnf-plugins-core-0.1.17-1.fc23 dnf-1.1.7-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0123ce82c1
Comment 6 Fedora Update System 2016-02-25 08:56:28 EST
dnf-plugins-core-0.1.17-1.fc22 dnf-1.1.7-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f673381075
Comment 7 Fedora Update System 2016-03-09 12:19:52 EST
dnf-1.1.7-2.fc23 dnf-plugins-core-0.1.17-1.fc23 libsolv-0.6.19-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0123ce82c1
Comment 8 Fedora Update System 2016-03-09 12:21:40 EST
dnf-1.1.7-2.fc22 dnf-plugins-core-0.1.17-1.fc22 libsolv-0.6.19-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f673381075
Comment 9 Fedora Update System 2016-03-10 11:53:04 EST
dnf-1.1.7-2.fc22, dnf-plugins-core-0.1.17-1.fc22, libsolv-0.6.19-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f673381075
Comment 10 Fedora Update System 2016-03-10 11:54:38 EST
dnf-1.1.7-2.fc23, dnf-plugins-core-0.1.17-1.fc23, libsolv-0.6.19-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0123ce82c1
Comment 11 Fedora Update System 2016-03-13 19:55:03 EDT
dnf-1.1.7-2.fc23, dnf-plugins-core-0.1.17-1.fc23, libsolv-0.6.19-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2016-03-19 08:16:10 EDT
dnf-1.1.7-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c030d24231
Comment 13 Fedora Update System 2016-03-19 23:58:00 EDT
dnf-1.1.7-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c030d24231
Comment 14 Fedora Update System 2016-03-26 13:57:49 EDT
dnf-1.1.7-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.