Bug 130541 - FAT32 formatted MO disk in /dev/sdb crashes installer
Summary: FAT32 formatted MO disk in /dev/sdb crashes installer
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-21 13:34 UTC by Joachim Frieben
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 13:43:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2004-08-21 13:34:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
Installation of FC2 exits abnormally on a Dual Pentium Pro PR440FX
SCSI only system when a FAT32 formatted media is present in the
installed Fujitsu MCE 3064SS MO drive.

Version-Release number of selected component (if applicable):
anaconda-10.0-5

How reproducible:
Always

Steps to Reproduce:
1. Insert FAT32 formatted media into MO drive.
2. Boot system from FC2 boot CD.
3. Pursue installation until installer exits.
    

Actual Results:  Installer issues "install exited abnormally" and
terminates the installation procedure.

Expected Results:  Installation procedure should continue without
aborting.

Additional info:

The boot CD drive is mapped onto /dev/scd0, the MO drive onto
/dev/sdb. Application of available install options like "text",
"noprobe", etc. and combinations hereof do not change the unfavourable
outcome.
Switching to /dev/tty4 reveals complaints about a non-ISO9660 media
present in /dev/sdb. Removal of the media from the MO drive hereafter
allowed to install FC2 without any further problem.
No failure of this kind was observed during a prior installation of
FC3 test 1 although the MO disk was present then, too.

Comment 1 Jeremy Katz 2004-08-23 14:54:47 UTC
If you switch to tty2 and run 'python -c "import kudzu; print
kudzu.probe(kudzu.CLASS_CDROM, kudzu.BUS_UNSPEC, 0)"' what do you get
as output?

Comment 2 Joachim Frieben 2004-08-24 21:45:01 UTC
Ok, switching between virtual consoles back and forth is still
possible after the termination notification and rebooting via
ctrl-alt-del, too. But after switching to tty2, the keyboard seems to
be stuck. Well, at least, there is no alphnumerical output on the
screen. Any clue how to get around this problem?

Comment 3 Jeremy Katz 2005-04-14 21:04:37 UTC
Does this still happen with fc4 test?

Comment 4 Joachim Frieben 2005-04-16 11:09:26 UTC
No, because as mentioned in my original bug report, this issue was already gone
as of FC3T1.

Comment 5 Jeremy Katz 2005-04-16 13:43:55 UTC
Oh, even better.  Almost certainly an artifact of the early-ish 2.6 kernel
shipped in fc2 then.


Note You need to log in before you can comment on or make changes to this bug.