Bug 1305484 - Disable editing of the hosted engine VM and storage (like rename) actions.
Disable editing of the hosted engine VM and storage (like rename) actions.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.3
x86_64 All
high Severity high
: ovirt-3.6.3
: 3.6.3
Assigned To: Roy Golan
Artyom
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 06:55 EST by Yaniv Lavi
Modified: 2016-03-21 09:50 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Editing a hosted engine VM using the GUI or API is disabled till its properly supported. An attempt to edit it will raise a validation message. Once Bug 1160094 is closed this can be enabled by default.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 09:50:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53425 master MERGED bll: Hosted Engine editing validator 2016-02-15 15:06 EST
oVirt gerrit 53547 ovirt-engine-3.6 MERGED bll: Hosted Engine editing validator 2016-02-16 01:58 EST
oVirt gerrit 53555 ovirt-engine-3.6.3 MERGED bll: Hosted Engine editing validator 2016-02-16 03:19 EST

  None (edit)
Description Yaniv Lavi 2016-02-08 06:55:43 EST
Description of problem:
This feature was not stable enough to be included in the GA. Since this is the case it was decided to block it for 3.6 RHEV GA and stabilize it for one of the maintenance releases.
Comment 1 Yaniv Lavi 2016-02-14 04:16:51 EST
Please do not block this in upstream since it will be a regression. Make this change only to D\S.
Comment 2 Roy Golan 2016-02-14 04:31:55 EST
(In reply to Yaniv Dary from comment #1)
> Please do not block this in upstream since it will be a regression. Make
> this change only to D\S.

This would be blocked per cluster level, by default blocked for 3.6, everything above is unblocked. 

Using engine-config could be unblocked for 3.6 as well.
Comment 4 Sandro Bonazzola 2016-02-16 04:29:00 EST
Missing update to RHEV-M spec file requiring the latest rhevm-setup-plugins.
Considering this on modified for upstream, still in POST for downstream.
Comment 5 Artyom 2016-02-17 09:01:18 EST
Hi Roy, can you please specify, what do we block, because I succeed to change HE vm name and also memory(it does not work, because bug connect to memory hotplug, but I do not see any validation error that prevent from me to edit HE VM).

Checked on rhevm-3.6.3.1-0.1.el6.noarch
Comment 6 Artyom 2016-02-21 07:41:37 EST
Verified on rhevm-setup-plugins-3.6.2-1.el6ev.noarch
rhevm-appliance-20160212.0-1.el7ev.noarch has old rhevm-setup-plugins package, so you need to update it manually to apply fix for bug.

Error while executing action: 

HostedEngine:
Cannot edit VM. The VM is a hosted engine and editing is not allowed. See configuration value AllowEditingHostedEngine.
Comment 7 Eyal Edri 2016-03-21 09:50:06 EDT
3.6.3 is released.

Note You need to log in before you can comment on or make changes to this bug.