Bug 1305493 - glusterfs logrotate config file clobbers defaults [rhel-6]
glusterfs logrotate config file clobbers defaults [rhel-6]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glusterfs (Show other bugs)
6.6
All Linux
high Severity high
: rc
: ---
Assigned To: sankarshan
Anoop
: Patch, ZStream
: 1279968 (view as bug list)
Depends On: 1171865
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 07:29 EST by Marcel Kolaja
Modified: 2016-06-19 21:18 EDT (History)
23 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0.55-1
Doc Type: Bug Fix
Doc Text:
When installing the glusterfs packages on Red Hat Enterprise Linux 6, the glusterfs-logrotate and glusterfs-georep-logrotate files were previously installed with several global logrotate options. Consequently, the global options affected the default settings in the /etc/logrotate.conf file. The glusterfs RPMs have been rebuilt to prevent the default settings from being overridden. As a result, global settings in /etc/logrotate.conf continue to function as configured without being overridden by settings from glusterfs logrotate files.
Story Points: ---
Clone Of: 1171865
Environment:
Last Closed: 2016-03-22 11:43:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1353853 None None None 2016-02-08 07:29 EST

  None (edit)
Description Marcel Kolaja 2016-02-08 07:29:35 EST
This bug has been copied from bug #1171865 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 3 Marcel Kolaja 2016-02-10 05:32:12 EST
*** Bug 1279968 has been marked as a duplicate of this bug. ***
Comment 8 Anoop 2016-03-15 11:52:37 EDT
Verified by QE.
Comment 11 errata-xmlrpc 2016-03-22 11:43:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0476.html

Note You need to log in before you can comment on or make changes to this bug.