Bug 1305515 - Rebase to >= 2.46
Rebase to >= 2.46
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glib2 (Show other bugs)
7.3
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Colin Walters
Desktop QE
: Rebase
: 1324837 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 08:21 EST by Colin Walters
Modified: 2016-11-03 21:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: glib2-2.46.2-2.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:39:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2257 normal SHIPPED_LIVE glib2 bug fix and enhancement update 2016-11-03 09:32:04 EDT

  None (edit)
Description Colin Walters 2016-02-08 08:21:19 EST
The next version of rpm-ostree will require a newer version of libhif which will require 2.46 or newer.
Comment 2 Colin Walters 2016-02-26 14:35:46 EST
Matthias, can you help me acquire a qa_ack?
Comment 3 Tomas Pelka 2016-03-07 15:49:08 EST
We have 2.42.2 in rhel7, Colin could you please sum up or link to list of changes compared to targeted 2.46? Or hints what to focus on.


Should we expect libhif rebase too?
Comment 4 Colin Walters 2016-03-07 20:50:30 EST
(In reply to Tomas Pelka from comment #3)
> We have 2.42.2 in rhel7, Colin could you please sum up or link to list of
> changes compared to targeted 2.46? Or hints what to focus on.

The NEWS file has the usuals:
https://git.gnome.org/browse/glib/tree/NEWS

Broadly speaking I don't think there's anything really risky.

> Should we expect libhif rebase too?

Probably, but you'd have to ask Richard for sure.  rpm-ostree (as used by Atomic Host) will carry a private copy.
Comment 6 Milan Crha 2016-04-07 08:18:50 EDT
This change forgot of the issue in the evolution-data-server, filled upstream as this bug [1]. I'm building evolution-data-server-3.12.11-28.el7 with the upstream fix included.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=755075
Comment 7 Vladimir Benes 2016-04-07 08:20:18 EDT
*** Bug 1324837 has been marked as a duplicate of this bug. ***
Comment 10 errata-xmlrpc 2016-11-03 21:39:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2257.html

Note You need to log in before you can comment on or make changes to this bug.