This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1305530 - Restoring a RAM snapshots in RHEL6.7 shows error stating the vm (even though it starts correctly) and fails to connect via spice(SetVmTicket: Unexpected exception)
Restoring a RAM snapshots in RHEL6.7 shows error stating the vm (even though ...
Status: CLOSED NEXTRELEASE
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.16.33
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Francesco Romani
Aharon Canan
virt
:
Depends On: 1307094
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 09:15 EST by Francesco Romani
Modified: 2016-02-21 06:18 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1260177
Environment:
Last Closed: 2016-02-15 08:24:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
libvirtd debug log (32.67 KB, application/x-gzip)
2016-02-11 05:12 EST, Francesco Romani
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44842 None None None 2016-02-08 09:15 EST
oVirt gerrit 45979 None None None 2016-02-08 09:15 EST
oVirt gerrit 46524 None None None 2016-02-08 09:15 EST
oVirt gerrit 47487 None None None 2016-02-08 09:15 EST

  None (edit)
Comment 1 Red Hat Bugzilla Rules Engine 2016-02-08 09:15:21 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 2 Red Hat Bugzilla Rules Engine 2016-02-08 09:15:48 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 3 Yaniv Lavi (Dary) 2016-02-08 09:23:20 EST
Please add public comment with info on what this bug is about.
Comment 4 Francesco Romani 2016-02-08 09:27:32 EST
Bug description:
Restoring a snapshot works but the VM cannot be accessed via spice. The error is "Error while executing action SetVmTicket: Unexpected exception".

This is reported to happen on 3.5.7, this bug is intended to track investigation of the issue.
Comment 7 Francesco Romani 2016-02-11 05:12 EST
Created attachment 1123108 [details]
libvirtd debug log
Comment 9 Jiri Denemark 2016-02-12 05:16:43 EST
So looking at the code, this seems to be the same issue as described in bug 1254164. We just need to backport the patches for RHEL-6. I'll clone that bug for 6.8 and make this one depend on it.
Comment 10 Francesco Romani 2016-02-12 05:31:36 EST
(In reply to Jiri Denemark from comment #9)
> So looking at the code, this seems to be the same issue as described in bug
> 1254164. We just need to backport the patches for RHEL-6. I'll clone that
> bug for 6.8 and make this one depend on it.

Thanks for the answer!

I don't know if this helps, or if it was already evident, but I think there are some differencies worth stressing:

1. this time we DO NOT have hooks involved (in 1254164 we had them)
2. AFAIU 1254164 wes due to some backports affecting libvirt 1.2.8 on RHEL7.1, I may be wrong on this

Reference https://bugzilla.redhat.com/show_bug.cgi?id=1254164#c7
Comment 11 Jiri Denemark 2016-02-12 12:20:01 EST
(In reply to Francesco Romani from comment #10)
> 1. this time we DO NOT have hooks involved (in 1254164 we had them)

Yeah, RHEL-6 does not support restore hooks, but the code path is the same

> 2. AFAIU 1254164 wes due to some backports affecting libvirt 1.2.8 on
> RHEL7.1, I may be wrong on this

It affected 7.1 because it was fixed upstream after 1.2.8 was released.
Comment 12 Jiri Denemark 2016-02-12 12:24:08 EST
I reproduced the issue (see bug 1307094 for steps), backported the fixes from upstream, and checked it's all working for me. Francesco, could you try the scratch build from https://brewweb.devel.redhat.com/taskinfo?taskID=10480048 and check it fixes this bug?
Comment 13 Francesco Romani 2016-02-15 04:22:47 EST
(In reply to Jiri Denemark from comment #12)
> I reproduced the issue (see bug 1307094 for steps), backported the fixes
> from upstream, and checked it's all working for me. Francesco, could you try
> the scratch build from
> https://brewweb.devel.redhat.com/taskinfo?taskID=10480048 and check it fixes
> this bug?

I did a quick test and looks good with the patched rpms. WORKSFORME.
Comment 14 Francesco Romani 2016-02-15 05:32:10 EST
On Vdsm side, we'll just need to consume the libvirt fix. Will post a patch once we know on which libvirt version we should depend.
Comment 16 Michal Skrivanek 2016-02-15 08:24:58 EST
closing as we do not intend to rebuild just to pick up a libvirt rpm.
Once libvirt is out on properly updated system this problem should be fixed

Note You need to log in before you can comment on or make changes to this bug.