Bug 1305550 - [RFE] pacemaker should reboot redis when service is depromoted from master
[RFE] pacemaker should reboot redis when service is depromoted from master
Status: CLOSED DUPLICATE of bug 1305549
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Angus Thomas
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 09:56 EST by Eduard Barrera
Modified: 2016-04-18 02:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 10:08:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduard Barrera 2016-02-08 09:56:14 EST
Description of problem:

Talking with Mehdi Abaakouk about a customer case suggested some improvements that are worth to include on OSP.

We had an issue where customer got the following error:

 ceilometer.coordination ToozError: You can't write against a read only slave 


Mehdi suggested the following improvement:

""" 
You also need to ensure that your pacemaker configuration stop/kill redis when its depromoted from master, otherwise Ceilometer will stay connected to it even haproxy marks the node as DOWN.
"""



Version-Release number of selected component (if applicable):

haproxy-1.5.4-4.el7_1.1.x86_64
openstack-puppet-modules-2015.1.8-21.el7ost.noarch
pacemaker-1.1.12-22.el7_1.4.x86_64
pacemaker-cli-1.1.12-22.el7_1.4.x86_64
pacemaker-cluster-libs-1.1.12-22.el7_1.4.x86_64
pacemaker-libs-1.1.12-22.el7_1.4.x86_64
pacemaker-remote-1.1.12-22.el7_1.4.x86_64
puppet-3.6.2-2.el7.noarch
rubygem-rdoc-4.0.0-25.el7_1.noarch




How reproducible:
not sure

Steps to Reproduce:
1. setup openstack HA
2. make celiometer to connect to mongodb
3. promote a slave mongodb to master

Actual results:

Ceilometer trying to write to a slave with the following error
 ceilometer.coordination ToozError: You can't write against a read only slave 


Expected results:

Ceilometer writing to the master mongodb server 


Additional info:
Comment 2 Mike Burns 2016-02-08 10:08:57 EST

*** This bug has been marked as a duplicate of bug 1305549 ***

Note You need to log in before you can comment on or make changes to this bug.