Bug 1305554 - include the '=' symbol in sssd man pages as delimiter between an option and a boolean
include the '=' symbol in sssd man pages as delimiter between an option and a...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
23
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 09:59 EST by Striker Leggette
Modified: 2016-02-11 03:52 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-11 03:52:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Striker Leggette 2016-02-08 09:59:11 EST
[+] Description of problem:
 - I have ran into a few cases where the use of sssd.conf did not contain the proper delimiter between the options and their booleans contained within.  The manuals should clearly state that the delimiter '=' is required.

[+] Actual results:
       enumerate (bool)

[+] Expected results:
       enumerate = (bool)
Comment 1 Jakub Hrozek 2016-02-08 10:03:03 EST
What I guess would even be better is for us to finally start validating the config..
Comment 2 Lukas Slebodnik 2016-02-08 10:59:18 EST
We might try to do a limited validation by python bindings.

sh$ rpm -ql sssd-common | grep /sssd/sssd.api.d
/usr/share/sssd/sssd.api.d
/usr/share/sssd/sssd.api.d/sssd-ad.conf
/usr/share/sssd/sssd.api.d/sssd-ipa.conf
/usr/share/sssd/sssd.api.d/sssd-krb5.conf
/usr/share/sssd/sssd.api.d/sssd-ldap.conf
/usr/share/sssd/sssd.api.d/sssd-local.conf
/usr/share/sssd/sssd.api.d/sssd-proxy.conf
/usr/share/sssd/sssd.api.d/sssd-simple.conf

Help on class SSSDConfig in module SSSDConfig:

class SSSDConfig(SSSDConfig.ipachangeconf.SSSDChangeConf)
 |  class SSSDConfig
 |  Primary class for operating on SSSD configurations
 |  
 |  Method resolution order:
 |      SSSDConfig
 |      SSSDConfig.ipachangeconf.SSSDChangeConf
 |      SSSDConfig.ipachangeconf.IPAChangeConf
 |  
 |  Methods defined here:
 |  
 |  __init__(self, schemafile=None, schemaplugindir=None)
 |      Initialize the SSSD config parser/editor. This constructor does not
 |      open or create a config file. If the schemafile and schemaplugindir
 |      are not passed, it will use the system defaults.
 |      
 |      schemafile:
 |        The path to the api schema config file. Usually
 |        /usr/share/sssd/sssd.api.conf
 |      schemaplugindir:
 |        The path the directory containing the provider schema config files.
 |        Usually /usr/share/sssd/sssd.api.d
Comment 3 Lukas Slebodnik 2016-02-08 11:10:12 EST
(In reply to Striker Leggette from comment #0)
> [+] Description of problem:
>  - I have ran into a few cases where the use of sssd.conf did not contain
> the proper delimiter between the options and their booleans contained
> within.  The manuals should clearly state that the delimiter '=' is required.
> 
> [+] Actual results:
>        enumerate (bool)
> 
> [+] Expected results:
>        enumerate = (bool)

I think it's clearly explained in the top of the sssd.conf manual page.

SSSD.CONF(5)             File Formats and Conventions             SSSD.CONF(5)

NAME
       sssd.conf - the configuration file for SSSD

FILE FORMAT
       The file has an ini-style syntax and consists of sections and
       parameters. A section begins with the name of the section in square
       brackets and continues until the next section begins. An example of
       section with single and multi-valued parameters:

           [section]
           key = value
           key2 = value2,value3

       The data types used are string (no quotes needed), integer and bool
       (with values of “TRUE/FALSE”).

       A line comment starts with a hash sign (“#”) or a semicolon (“;”).
       Inline comments are not supported.

       All sections can have an optional description parameter. Its function
       is only as a label for the section.

       sssd.conf must be a regular file, owned by root and only root may read
       from or write to the file.


In my opinion it might be confusing for users.
People might think they need to add boolean value to brackets.
e.g.
"enumerate = (true)" 

We are consistent in this think and do not use character "=" between name on option and it's type.

I would close this ticket as not a bug.
Comment 4 Lukas Slebodnik 2016-02-11 03:52:26 EST
There was not any objections for closing the ticket (Comment 2).
I will close it as won't fix.
Feel free to reopen with clarification if you disagree.

Note You need to log in before you can comment on or make changes to this bug.