Bug 130558 - Kernel panic: Attempted to kill init!
Kernel panic: Attempted to kill init!
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-08-21 15:42 EDT by Marc Mondragon
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:53:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Serial Console capture with no apic or acpi paramters (27.69 KB, text/plain)
2004-08-21 15:43 EDT, Marc Mondragon
no flags Details
Serial console capture with noapic and acpi=off kernel parameters (23.15 KB, text/plain)
2004-08-21 15:45 EDT, Marc Mondragon
no flags Details

  None (edit)
Description Marc Mondragon 2004-08-21 15:42:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
MSI KT8N Neo based machine.  Initially installed FC2 x86_64 tried to
load FC3 test1 via CD's but had problem's (I recently submitted a bug
report on this).  So I updated the machine via yum and the development
channel which went fine but the machine has never booted successfully
with the FC3 kernels or Arjan's kernels.  I kept a kernel of the
2.6.6-1.435.2.3 vintage around and it's the last one I've had work and
what I'm currently using.  I'll attach two caps I made from the serial
console.  One with noapic and acpi=off the other with them on.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.525

How reproducible:
Always

Steps to Reproduce:
1. Down load new kernel
2. Reboot

    

Actual Results:  Kernel and/or init panics

Expected Results:  Machine boots

Additional info:
Comment 1 Marc Mondragon 2004-08-21 15:43:51 EDT
Created attachment 102956 [details]
Serial Console capture with no apic or acpi paramters
Comment 2 Marc Mondragon 2004-08-21 15:45:17 EDT
Created attachment 102957 [details]
Serial console capture with noapic and acpi=off kernel parameters
Comment 3 Ronny Buchmann 2004-10-19 16:42:42 EDT
does it work with test3 or current rawhide?
Comment 4 Marc Mondragon 2004-10-19 17:48:26 EDT
It does.  I wasn't able to install with FC3t3 as it was released but
on the fedora-test list I saw a message the mentioned that the
sata_nv.ko module was mistaking not included in the DVD/CD ISO initrd.
 Someone pointed me to a new development boot.iso and I was able to
install using it without a problem.  As far as rawhide updates are
concerned, as of the 624 kernel I don't have to do a thing when I
update a kernel.  Before that I had to rebuild the initrd using the
--with=sata_nv switch to get a kernel that would boot.
Comment 5 Dave Jones 2005-07-15 15:11:02 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Marc Mondragon 2005-07-15 16:36:14 EDT
I've since upgraded this machine to FC4 and it boots fine.

Note You need to log in before you can comment on or make changes to this bug.