Bug 130560 - Upgrade to mutt 1.5 (development branch)
Upgrade to mutt 1.5 (development branch)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
ftp://ftp.mutt.org/mutt/devel/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-21 17:33 EDT by Robert Scheck
Modified: 2014-03-16 22:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5:1.5.13-1.20070126cvs
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 16:47:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff between mutt 1.4.1-9 and mutt 1.5.6-1 (5.64 KB, patch)
2004-08-21 17:35 EDT, Robert Scheck
no flags Details | Diff
mutt-1.5.6-nosetgid.patch (1.51 KB, patch)
2004-08-21 17:36 EDT, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2004-08-21 17:33:42 EDT
Description of problem:
Currently, we've got the stable branch (1.4) of mutt packaged in 
Fedora Core Development, but the unstable/development branch (1.5) 
of mutt would be better, because mutt 1.5 has more features (eg. 
IDN support - umlaut domains, interesting in Europe) and many bug 
fixes for a lot of problems and there are also patches for other 
requests (eg. gzip mailbox or nntp support or dynamically threads).

I think Fedora Core/Red Hat also should switch to mutt 1.5, because  
SuSE (Novell), Mandrake, Debian, Gentoo and others already switched 
to mutt 1.5 in there unstable trees, some of them even already in 
their official releases.

Version-Release number of selected component (if applicable):
mutt-1.4.1-9

Actual results:
I'll attach a diff from a patch between 1.4.1-9 to 1.5.6-1 and the 
merged patches - and I would be happy about a change to 1.5.6.

Expected results:
Upgrade to mutt 1.5.6 (development branch).
Comment 1 Robert Scheck 2004-08-21 17:35:49 EDT
Created attachment 102959 [details]
Diff between mutt 1.4.1-9 and mutt 1.5.6-1
Comment 2 Robert Scheck 2004-08-21 17:36:13 EDT
Created attachment 102960 [details]
mutt-1.5.6-nosetgid.patch
Comment 3 Bill Nottingham 2004-08-23 15:08:30 EDT
We're not going to ship a development upstream version.
Comment 4 Robert Scheck 2004-08-23 16:27:22 EDT
Why? Could you tell me a good reason for this strance decision? 
Anaconda, Bind, Gaim, Hal, KDE, Libtheora, Ntp, Nvi-m17n, RPM, Samba, 
Spamassassin, Wordtrans, Xorg-X11 and other packages are currently as 
unstable/cvs/development or other non-released things at Rawhide 
available. Why aren't mutt development releases there available, too?!

Fedora Core Development aka Rawhide is the unstable tree of FC and 
RHEL and is known to have the latest versions of packages...
Comment 5 Bill Nottingham 2004-08-23 16:47:40 EDT
xorg, kde, etc will all be released by the time the next release ships.

theora doesn't have a stable release version...

Moreover, it's not like samba is shipping a Samba 4 HEAD, etc.
Comment 6 Robert Scheck 2007-02-10 16:52:22 EST
Bill, it looks like Miroslav Lichvar, the current mutt maintainer at Red Hat, 
heared my wish after years... ;-)

Note You need to log in before you can comment on or make changes to this bug.