Bug 1305613 - uglify-js-2.6.1 is available
uglify-js-2.6.1 is available
Product: Fedora
Classification: Fedora
Component: uglify-js (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: T.C. Hollingsworth
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-02-08 12:36 EST by Sander Hoentjen
Modified: 2016-02-13 05:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-02-13 05:47:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sander Hoentjen 2016-02-08 12:36:23 EST
Can you please update uglify-js in rawhide? I get a weird build error [1]:

uglifyjs src_js/jquery.js > html/js/jquery.min.js
/bin/sh: line 1: 15923 Segmentation fault      (core dumped) uglifyjs src_js/jquery.js > html/js/jquery.min.js

When I do a local mockbuild I see:
uglifyjs src_js/jquery.js > html/js/jquery.min.js
(node) util.print is deprecated. Use console.log instead.

I guess the deprecation notice is causing the issue in kjoi, but that should be fixed in the new version.

[1] https://kojipkgs.fedoraproject.org//work/tasks/4099/12904099/build.log
Comment 1 Sander Hoentjen 2016-02-11 05:01:57 EST
Anything I can do to help this move along?
Comment 2 Sander Hoentjen 2016-02-13 05:47:08 EST
Heh, turns out Tom Hughes already updated, so thanks

Note You need to log in before you can comment on or make changes to this bug.