Bug 1305623 - Nikola won't run due to incompatible library version for python-dateutil
Nikola won't run due to incompatible library version for python-dateutil
Status: CLOSED DUPLICATE of bug 1268039
Product: Fedora
Classification: Fedora
Component: python-nikola (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Pete Travis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 13:34 EST by David Yaffe
Modified: 2016-02-09 09:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 09:09:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Yaffe 2016-02-08 13:34:26 EST
Description of problem:
Nikola will not run due to missing version dependency in Fedora 23. Nikola requires python-dateutil==2.4.1, however python-dateutil==2.4.2 is in the repository.

Version-Release number of selected component (if applicable):
python-nikola-7.3.1-3.fc23.noarch

How reproducible:
everytime

Steps to Reproduce:
1. dnf install python-nikola
2. nikola init testsite
3. crash!

Actual results:
[david@example ~]$ nikola init testsite
Traceback (most recent call last):
  File "/usr/bin/nikola", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 653, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 666, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'python-dateutil==2.4.1' distribution was not found and is required by Nikola


Expected results:
$ nikola init --demo my_first_site
Creating Nikola Site
====================

This is Nikola.  We will now ask you a few easy questions about your new site.
If you do not want to answer and want to go with the defaults instead, simply restart with the `-q` parameter.
--- Questions about the site ---
Site title [My Nikola Site]: My First Nikola Site
...a couple more questions...

That's it, Nikola is now configured.  Make sure to edit conf.py to your liking.
If you are looking for themes and addons, check out https://themes.getnikola.com/ and https://plugins.getnikola.com/.
Have fun!
INFO: init: A new site with example data has been created at my_first_site.
INFO: init: See README.txt in that folder for more information.


Additional info:
Comment 1 David Yaffe 2016-02-08 13:38:52 EST
This also affects python3-nikola. I'll file a bug there too, as support for python 2.7 is being deprecated, see https://getnikola.com/blog/env-survey-results-and-the-future-of-python-27.html
Comment 2 Pete Travis 2016-02-09 09:09:13 EST

*** This bug has been marked as a duplicate of bug 1268039 ***

Note You need to log in before you can comment on or make changes to this bug.