Bug 1305636 - AttributeError: 'Expander' object has no attribute 'members'
AttributeError: 'Expander' object has no attribute 'members'
Status: CLOSED DUPLICATE of bug 1309018
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:9538767c64ab47cb9c2e146c528...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 14:17 EST by stan
Modified: 2016-02-29 09:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 09:42:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (907.98 KB, text/plain)
2016-02-08 14:17 EST, stan
no flags Details
File: anaconda.log (78.33 KB, text/plain)
2016-02-08 14:17 EST, stan
no flags Details
File: dnf.log (1.32 KB, text/plain)
2016-02-08 14:17 EST, stan
no flags Details
File: environ (459 bytes, text/plain)
2016-02-08 14:17 EST, stan
no flags Details
File: lsblk_output (4.11 KB, text/plain)
2016-02-08 14:17 EST, stan
no flags Details
File: nmcli_dev_list (1.25 KB, text/plain)
2016-02-08 14:17 EST, stan
no flags Details
File: os_info (451 bytes, text/plain)
2016-02-08 14:17 EST, stan
no flags Details
File: storage.log (317.72 KB, text/plain)
2016-02-08 14:17 EST, stan
no flags Details
File: syslog (94.45 KB, text/plain)
2016-02-08 14:17 EST, stan
no flags Details
File: ifcfg.log (1.69 KB, text/plain)
2016-02-08 14:17 EST, stan
no flags Details
File: packaging.log (715 bytes, text/plain)
2016-02-08 14:17 EST, stan
no flags Details
File: program.log (260.07 KB, application/octet-stream)
2016-02-08 14:17 EST, stan
no flags Details

  None (edit)
Description stan 2016-02-08 14:17:07 EST
Description of problem:
Installing rawhide using bfo.  Custom partitioning of existing partitions failed.

Version-Release number of selected component:
anaconda-24.11-1

The following was filed automatically by anaconda:
anaconda 24.11-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 304, in remove_page
    for s in target.members:
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 904, in _do_reformat
    self._accordion.remove_page(page.pageTitle)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 137, in decorated
    return func(*args, **kwargs)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1232, in _save_right_side
    encrypted, selector, fs_type)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2288, in _save_current_page
    self._save_right_side(selector)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2373, in on_page_clicked
    self._save_current_page()
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 107, in _on_expanded
    cb(obj.get_child())
AttributeError: 'Expander' object has no attribute 'members'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   repo=http://download.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/ initrd=http://download.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/images/pxeboot/initrd.img BOOT_IMAGE=http://download.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/images/pxeboot/vmlinuz 
dnf.rpm.log:    Feb 08 19:07:31 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.5.0-0.rc2.git3.1.fc24.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide
Comment 1 stan 2016-02-08 14:17:23 EST
Created attachment 1122226 [details]
File: anaconda-tb
Comment 2 stan 2016-02-08 14:17:26 EST
Created attachment 1122227 [details]
File: anaconda.log
Comment 3 stan 2016-02-08 14:17:26 EST
Created attachment 1122228 [details]
File: dnf.log
Comment 4 stan 2016-02-08 14:17:28 EST
Created attachment 1122229 [details]
File: environ
Comment 5 stan 2016-02-08 14:17:29 EST
Created attachment 1122230 [details]
File: lsblk_output
Comment 6 stan 2016-02-08 14:17:30 EST
Created attachment 1122231 [details]
File: nmcli_dev_list
Comment 7 stan 2016-02-08 14:17:30 EST
Created attachment 1122232 [details]
File: os_info
Comment 8 stan 2016-02-08 14:17:36 EST
Created attachment 1122233 [details]
File: storage.log
Comment 9 stan 2016-02-08 14:17:39 EST
Created attachment 1122234 [details]
File: syslog
Comment 10 stan 2016-02-08 14:17:39 EST
Created attachment 1122235 [details]
File: ifcfg.log
Comment 11 stan 2016-02-08 14:17:40 EST
Created attachment 1122236 [details]
File: packaging.log
Comment 12 stan 2016-02-08 14:17:45 EST
Created attachment 1122237 [details]
File: program.log
Comment 13 Jan Kurik 2016-02-24 09:26:52 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 14 David Shea 2016-02-29 09:42:55 EST

*** This bug has been marked as a duplicate of bug 1309018 ***

Note You need to log in before you can comment on or make changes to this bug.