Bug 1305648 - problem in package deps
problem in package deps
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 14:59 EST by ManPau
Modified: 2016-02-09 15:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 16:09:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ManPau 2016-02-08 14:59:46 EST
Description of problem:

I'm on Fedora 23 64bit:

[root@xxx ~]# uname -a
Linux xxx 4.3.5-300.fc23.x86_64 #1 SMP Mon Feb 1 03:18:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


I have this repos configured:

[root@xxx ~]# dnf repolist
Last metadata expiration check performed 0:14:26 ago on Mon Feb  8 20:38:41 2016.
repo id                                                   repo name                                                                 status
adobe-linux-x86_64                                        Adobe Systems Incorporated                                                    2
*fedora                                                   Fedora 23 - x86_64                                                        46074
rpmfusion-free                                            RPM Fusion for Fedora 23 - Free                                             692
rpmfusion-free-updates                                    RPM Fusion for Fedora 23 - Free - Updates                                   239
rpmfusion-free-updates-testing                            RPM Fusion for Fedora 23 - Free - Test Updates                              239
rpmfusion-nonfree                                         RPM Fusion for Fedora 23 - Nonfree                                          206
rpmfusion-nonfree-updates                                 RPM Fusion for Fedora 23 - Nonfree - Updates                                 80
rpmfusion-nonfree-updates-testing                         RPM Fusion for Fedora 23 - Nonfree - Test Updates                            80
spot-chromium                                             Copr repo for chromium owned by spot                                         30
*updates                                                  Fedora 23 - x86_64 - Updates                                              15569



[root@xxx ~]# dnf check-update
Last metadata expiration check performed 0:06:38 ago on Mon Feb  8 20:38:41 2016.



When I try to "dnf install wine" than dnf complains about the 32bit wine requiring wine-twain (32bit) even if it should install 64bit wine because I am on Fedora 64bit:

[root@xxx ~]# dnf install wine
Last metadata expiration check performed 0:06:47 ago on Mon Feb  8 20:38:41 2016.
Error: package wine-1.9.1-1.fc23.i686 requires wine-twain(x86-32) = 1.9.1-1.fc23, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)



Even when I try to explicitely install wine.x86_64 than it complains about wine-twain 32bit:
[root@xxx ~]# dnf install wine.x86_64
Last metadata expiration check performed 0:06:52 ago on Mon Feb  8 20:38:41 2016.
Error: package wine-1.9.1-1.fc23.x86_64 requires wine-twain(x86-32) = 1.9.1-1.fc23, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)



Version-Release number of selected component (if applicable):


How reproducible:
try to install wine from repository



Steps to Reproduce:
1. see above
2.
3.

Actual results:
wine can't be installed

Expected results:
wine gets installed
Comment 1 Michael Cronenworth 2016-02-08 16:09:00 EST
There is nothing wrong here.

If someone goes "dnf install wine" we want them to get everything.

If you want only 64-bit packages, which won't run much Windows software since a majority is 32-bit, you can "dnf remove wine" and then manually remove the 32-bit packages.
Comment 2 ManPau 2016-02-09 14:12:37 EST
I understand that it's intended to install everything (64bit wine stuff as well as 32bit wine stuff) when somebody runs "dnf install wine".

But what I don't understand is that nothing gets installed:
[root@xxx ~]# dnf install wine
Last metadata expiration check performed 0:03:43 ago on Tue Feb  9 20:05:25 2016.
Error: package wine-1.9.1-1.fc23.i686 requires wine-twain(x86-32) = 1.9.1-1.fc23, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

[root@xxx ~]# dnf list installed | grep wine
[root@xxx ~]#



So from my view there's something wrong in the repository or in the dependency definitions of the wine package(s)...
(hope this is the right way to report that kind of bugs/issues...)
Comment 3 Michael Cronenworth 2016-02-09 15:14:52 EST
Yes, you have a mirror issue or something not related to the package.

You can clean the dnf cache, check your mirror, or download the package off a functional mirror.

https://dl.fedoraproject.org/pub/fedora/linux/updates/23/x86_64/w/

Troubleshooting this further can be done on the support mailing list.

https://lists.fedoraproject.org/mailman/listinfo/users

Note You need to log in before you can comment on or make changes to this bug.