Bug 1305670 - RFE: add --pg-num to osdmaptool --test-map-pgs to allow the user to experiment with other pg counts
RFE: add --pg-num to osdmaptool --test-map-pgs to allow the user to experime...
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS (Show other bugs)
3.0
Unspecified Unspecified
urgent Severity urgent
: rc
: 3.0
Assigned To: Josh Durgin
Ramakrishnan Periyasamy
Erin Donnelly
: FutureFeature
Depends On:
Blocks: 1494421
  Show dependency treegraph
 
Reported: 2016-02-08 15:47 EST by Samuel Just
Modified: 2017-12-05 18:29 EST (History)
9 users (show)

See Also:
Fixed In Version: RHEL: ceph-12.1.4-1.el7cp Ubuntu: ceph_12.1.4-2redhat1xenial
Doc Type: Enhancement
Doc Text:
.A new `--pg-num` option for the `osdmaptool` utility The `osdmaptool` utility now includes the `--pg-num` option that can be used with the `--test-map-pgs` option. This allows the user to test placement policies with a different number of placement groups (PGs) than are in the OSD map.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-05 18:29:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 14701 None None None 2016-02-08 15:48 EST

  None (edit)
Description Samuel Just 2016-02-08 15:47:40 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 7 Ramakrishnan Periyasamy 2017-09-04 08:10:50 EDT
Moving this bug to verified state.

Command console output:

[ubuntu@host031 ~]$ sudo osdmaptool --test-map-pgs --pg-num 64 ./osdmap 
osdmaptool: osdmap file './osdmap'
pool 1 pg_num 64
pool 2 pg_num 64
#osd	count	first	primary	c wt	wt
osd.0	42	12	12	0.904388	1
osd.1	51	12	12	0.904388	1
osd.2	40	15	15	0.904388	1
osd.3	51	14	14	0.904388	1
osd.4	42	15	15	0.904388	1
osd.5	40	13	13	0.904388	1
osd.6	35	15	15	0.904388	1
osd.7	46	21	21	0.904388	1
osd.8	37	11	11	0.904388	1
 in 9
 avg 42 stddev 5.37484 (0.127972x) (expected 6.1584 0.146629x))
 min osd.6 35
 max osd.1 51
size 0	0
size 1	0
size 2	0
size 3	128
Comment 13 errata-xmlrpc 2017-12-05 18:29:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387

Note You need to log in before you can comment on or make changes to this bug.