Bug 1305686 - rhel-osp-director: Overcloud update from 7.2-> 7.3 fails "resources.SwiftDevicesAndProxyConfig: Property controller_swift_proxy_memcaches_v6 not assigned "
rhel-osp-director: Overcloud update from 7.2-> 7.3 fails "resources.SwiftDevi...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity unspecified
: y3
: 7.0 (Kilo)
Assigned To: Ryan Brown
Omri Hochman
: ZStream
Depends On:
Blocks: 1300847
  Show dependency treegraph
 
Reported: 2016-02-08 16:52 EST by Mike Burns
Modified: 2016-04-26 09:44 EDT (History)
15 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.6-117.el7ost
Doc Type: Bug Fix
Doc Text:
A bug in Heat caused validation of old parameters against the new template. Upgrades of Overclouds from Red Hat OpenStack Platform 7.2 to Red Hat OpenStack Platform 7.3 failed with the error: "resources.SwiftDevicesAndProxyConfig: Property controller_swift_proxy_memcaches_v6 not assigned". This fix add defaults to Swift parameters in the director's Heat template collection, which resolves the error.
Story Points: ---
Clone Of: 1300847
Environment:
Last Closed: 2016-02-18 11:52:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Ryan Brown 2016-02-08 19:48:59 EST
I've pushed a patch for review, it would be great if QA could try an update with this patch applied to the new (7.3) tripleo-heat-templates to validate the fix before merging it.
Comment 3 Omri Hochman 2016-02-16 15:43:47 EST
verified with: openstack-tripleo-heat-templates-0.8.6-120.el7ost.noarch
Comment 5 errata-xmlrpc 2016-02-18 11:52:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html

Note You need to log in before you can comment on or make changes to this bug.