Bug 13057 - Wyse Terminal Left Arrow now Backspaces
Wyse Terminal Left Arrow now Backspaces
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: termcap (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-26 10:53 EDT by Scott Sharkey
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-26 10:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Sharkey 2000-06-26 10:53:35 EDT
We are using an Accuware Cobol accounting package which uses a Wyse60
terminal emulation, with PC clients using TinyTerm.  Everything works
fine.  After upgrading to RH 6.2, the left arrow now sends a 
destructive backspace, instead of the left arrow function.  There is
no .inputrc or .termcap file in the local user directories.  

The left arrow definition (in fact the whole terminal definition)
does not appear to have changed when comparing the 6.1 and 6.2 
terminfo and termcap entries.  The left arrow is defined to send
a ^H, but apparently this is now being translated at a lower
level to a destructive backspace.

Is there a way to fix this?

-Scott Sharkey
Linux Unlimited, LLC
ssharkey@linux-no-limits.com
Comment 1 Bernhard Rosenkraenzer 2000-06-26 13:22:29 EDT
A ^H is a backspace... This was one of the bugfixes in 6.2.
I think you need to fix the client or play with its options.
Comment 2 Scott Sharkey 2000-06-26 17:41:32 EDT
Excuse me, but this is NOT a client issue.  Since that is what the terminal
sends, then there is no way to "fix the client" -- that is the defined
ASCII code for that key. That's what real Wyse60 terminals send when you
hit the left arrow. Are you saying that there is no way to pass
the ^H through without the kernel (or something) processing it?

-Scott

Note You need to log in before you can comment on or make changes to this bug.