Bug 130572 - /sbin/start_udev calls unrunnable program
/sbin/start_udev calls unrunnable program
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-21 20:40 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 04:22:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-08-21 20:40:28 EDT
Description of problem:

When booting with udev active my console is flooded with errors
like that:
...................
/sbin/pam_console_setowner: error while loading shared libraries:
libglib-2.0.so.0: cannot open shared object file: No such file or
directory
/sbin/pam_console_setowner: error while loading shared libraries:
libglib-2.0.so.0: cannot open shared object file: No such file or
directory
/sbin/pam_console_setowner: error while loading shared libraries:
libglib-2.0.so

It is not obvious to me what really call 'pam_console_setowner'
but clearly 'udev' is responsible because booting without it
immediately shuts that down.

The problem is that 'pam_console_setowner' is using
/usr/lib/libglib-2.0.so shared library and at the time this
is called /usr may be not available yet.  If copies of
this shared library are made on / then 'udev' complaints
like above disappear.

Version-Release number of selected component (if applicable):
udev-030-3

How reproducible:
Always

Note You need to log in before you can comment on or make changes to this bug.