Bug 130573 - /sbin/start_udev is using /usr/bin/seq
/sbin/start_udev is using /usr/bin/seq
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-21 20:52 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 04:18:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-08-21 20:52:50 EDT
Description of problem:

When booting with 'udev' I see:

Switching to new root
INIT: version 2.85 booting
Making extra nodes:  /sbin/start_udev: line 38: seq: command not found

/usr is not mounted at this point and 'seq' is really /usr/bin/seq
so the complaint is valid.  An obvious patch is to use
....
for i in 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15; do
....
instead of 'for i in `seq 0 15`; do

Actually when booting with initrd made with '--noudev' flag
I see also:

ln: cannot remove `/dev//fd': Read-only file system
ln: cannot remove `/dev//stdin': Read-only file system
ln: cannot remove `/dev//stdout': Read-only file system
ln: cannot remove `/dev//stderr': Read-only file system

Although this seems to be really a fault of /etc/rc.d/rc.sysinit
which tries to start not really available udev but likely

        ln -snf /proc/self/fd $udev_root/fd
        ln -snf /proc/self/fd/0 $udev_root/stdin
        ln -snf /proc/self/fd/1 $udev_root/stdout
        ln -snf /proc/self/fd/2 $udev_root/stderr
        ln -snf /proc/kcore $udev_root/core

instead of forcing them with '-f' should be guarded by
existence tests.

Version-Release number of selected component (if applicable):
udev-030-3

How reproducible:
Always

Note You need to log in before you can comment on or make changes to this bug.